No DFU Device Found

I have a 2 mic ReSpeaker array which I am using to build a picroft. Setup see’s the array and it’s available in the menu, however, it seems to have an issue with the drivers. I get “ValueError: No DFU device found”

How do you want Mycroft to output audio:

  1. Speakers via 3.5mm output (aka ‘audio jack’ or ‘headphone jack’)
  2. HDMI audio (e.g. a TV or monitor with built-in speakers)
  3. USB audio (e.g. a USB soundcard or USB mic/speaker combo)
  4. Google AIY Voice HAT and microphone board (Voice Kit v1)
  5. ReSpeaker Mic Array v2.0 (speaker plugged in to Mic board)

Cloning into ‘usb_4_mic_array’…
remote: Enumerating objects: 79, done.
remote: Total 79 (delta 0), reused 0 (delta 0), pack-reused 79
Unpacking objects: 100% (79/79), done.
Traceback (most recent call last):
File “”, line 229, in
File “/home/pi/mycroft-core/.venv/lib/python3.7/site-packages/click/”, line 764, in call
return self.main(*args, **kwargs)
File “/home/pi/mycroft-core/.venv/lib/python3.7/site-packages/click/”, line 717, in main
rv = self.invoke(ctx)
File “/home/pi/mycroft-core/.venv/lib/python3.7/site-packages/click/”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/pi/mycroft-core/.venv/lib/python3.7/site-packages/click/”, line 555, in invoke
return callback(*args, **kwargs)
File “”, line 218, in main
dev = XMOS_DFU()
File “”, line 198, in init
super(XMOS_DFU, self).init()
File “”, line 73, in init
raise ValueError(‘No DFU device found’)
ValueError: No DFU device found

It seems to me that it keeps downloading the 4 mic usb array. I’m assuming there is a 2 mic usb array, but the only drivers that it has ever pulled down is the 4 mic usb array. I found a similar issue in the forum, and the suggestion was to use a set of drivers from github, but they did not help when I tried them.

Any suggestion on how to move past this issue?

Thank you.

I finally made progress. I did a fresh picroft install and this time I skipped the setup wizard and installed the drivers from github manually. They installed without error and I am now able to get this to work.


I’m encountering the same problem, but I’m not great with Linux. How do you install drivers manually? When you bypass the wizard, what other manual steps do you have to do besides driver install to get it working?

Its been awhile since I worked with this, and my memory is a bit fuzzy. I ran into another issue and decided to put it to the side for now. I can’t seem to find the documentation that I was reading, but here on, there is a nice tutorial that you can follow.

ReSpeaker 2-Mics Pi HAT

Scroll down to 2. Setup the driver on Raspberry Pi