No data from GPRS shield


I have the latest GPRS shield and am trying to get it to work with the Arduino Uno. I have used previous shields before and they worked.

What is happening is that I am not getting any data from it. Usually it will send those initial random characters, the startup sequence and then Call Ready. But now all I get are the random characters.

I have also tried to upgrade the firmware and reset the baud rate but to no avail. I have tried three shields but none of them work.

I am using SoftwareSerial and the code from the Wiki.

please sent the result and hardware installation photo here, and IDE you are using .

I swap between an Uno and a Duemilanove but both give me the exact same result.

I am using the Arduino IDE, 1.0.1.

I attached the images.

Ok I think it’s firmware related.

I have an old GPRS shield that was working fine. I decided to upgrade the firmware and it started doing the same thing as above.

Any ideas?

I found the issue. The firmware works.

Just after it’s uploaded when setting the baud rate I have to use uppercase letters or it doesn’t work. After that I can use anything.