Newly aquired Jetson Orin NX will not boot up on inital setup

My new Jetson Orin NX will not boot up on first setup. The datasheet and description of the product suggests that jetpack and an OS would be preinstalled on the J40 Series Dev-Kits. That however seems to either not be the case for my Jetson or some other issue has occured.
I have attempted to:

  • put the Jetson into Force Recovery and reflash using SDK-Manager on a Host-PC over USB-c but the Jetson does not appear to be found by the Ubuntu 20.4 Host-PC 16GB RAM.
    I did check weather the USBc could be at fault.
    -use other boot options in the setup mode and boot menu of the Jetson itself using DVD bootable Ubuntu Iso and exhausted other boot options present in the boot menu.
    I am at a loss at to what may be causing the Jetsons inability to boot on NMVe, other mediums and communicate with any Host PCs.

I am at my wits end so any help would be apprechiated.


Hi there,
Man that sux, allot of coin to spend on a Desk ornament. Let’s see if we can deduce what the sam hill is going on?
How is the memory module installed AOK, visually inspect that.
Can you try a windows machine, does it enumerate the device when plugged in?
Any Jumper configuration , to choose the boot device? ( I recall a set of pins with jumper ? to boot from Nvme or Flash?) might be another carrier board?
GL :wink: PJ :crossed_fingers:

I look over the sales page and Either you got something else , but from the description doesn’t appear you got what you ordered? States more than once that it(“reComputer J4012 is preinstalled with JetPack 5.1.1 on the included 128GB NVMe SSD” )

Had the same issue just today! Fan wasn’t spinning or would only spin intermittently and no display output. Super frustrated but… I just check the cables. Powered it down, waited a minute, then powered up again.

Then again… and again… and on the 4th reboot or so it worked! It was immediately clear it was working because the fan immediately turned on and spun constantly.

Good luck!

The memory module is very likely installed under the cooler which i am not comfortable removing especially because I may have to return the product. The boot manager however does seem to at least recognize the NVMe and the distributors datasheet suggests they installed it & flashed it with Jetpack 5.1, which it says on their webside.
Reichelt is a german distributor so their webside is likely not helpful but that is the datasheet provided in english.
I did use a jumper cable to make the Jetson Orin enter recovery mode by using onboard pins which notably made a difference since it makes the fans stop for a second but it was not receptive using lsusb on my Hostpc nonetheless.
Using other media like USB to boot did work well too. I tried Ubuntu 20.4 ARCH64 image which enabled the ubuntu menu for a second however upon selecting “install/try ubuntu” the fans stopped again and display went to black…

I am starting to think the drive is not the culprit here…

the fan does run for minute while displaying the nvidia logo but it does go off again after supposedly booting and my monitor displays “display not supported” which made me think it was a monitor issue initially but given the fact the fans stop entirely and other boot media have failed aswell i am beggining to suspect the issue might be somewhere else.