New reTerminal, powers up with blank screen

So I got networking working, and reflashed the eMMC with SSH support.

After SSHing in, I could upgrade the OS but nothing available except via SSH - vcgencmd thinks there is no display, which is a big possibility as to why the LCD screen isn’t displaying anything…

I encountered the same or a similar issue. Powered up normally. Initial setup asked to upgrade software, the system including touch screen got stuck during the upgrade. After waiting for some hours I unplugged the device, plugged it back in and the screen stayed black. I was able to finish the upgrade via SSH, but this did not help.

dmesg repeatedly logs the following (approx 500 ms between repeated entries):

[ xxxx.xxxxxx] hdmi-audio-codec ASoC: error at snd_soc_component_set_jack on -95
[ 3112.805324] vc4-drm gpu: bound fe400000.hvs (ops vc4_hvs_ops [vc4])
[ 3112.805982] Registered IR keymap rc-cec
[ 3112.806332] rc rc0: vc4 as /devices/platform/soc/fef00700.hdmi/rc/rc0
[ 3112.806435] input: vc4 as /devices/platform/soc/fef00700.hdmi/rc/rc0/input16033
[ 3112.812424] vc4-drm gpu: bound fef00700.hdmi (ops vc4_hdmi_ops [vc4])
[ 3112.819476] Registered IR keymap rc-cec
[ 3112.819574] rc rc1: vc4 as /devices/platform/soc/fef05700.hdmi/rc/rc1
[ 3112.819672] input: vc4 as /devices/platform/soc/fef05700.hdmi/rc/rc1/input16034
[ 3112.825904] vc4-drm gpu: bound fef05700.hdmi (ops vc4_hdmi_ops [vc4])
[ 3112.946899] hdmi-audio-codec ASoC: error at snd_soc_component_set_jack on -95
[ 3113.057284] hdmi-audio-codec ASoC: error at snd_soc_component_set_jack on -95
[ xxxx.xxxxxx] vc4-drm gpu: bound fe400000.hvs (ops vc4_hvs_ops [vc4])

I have now flashed the eMMC with Ubuntu Desktop 21.04, and also the current Raspberry Pi OS - in both cases the screen never goes online.

Is it possible that some module ha to be enable to make the screen work?

1 Like

Hi all,

I have a workable solution that might help many of you:

  1. Prepare your reTerminal as outline above
  2. Download this prebuilt image, made by Seeed Studio:
  3. Use the rpi-imager to flash the eMMC
  4. Use a decent USB-C power supply - the DSI LCD is sensitive to power drops - I cannot use my own Desktop PC to power it, I currently use a Dell USB-C power supply

@lcnittl, If you don’t use the Seeed Studio image, you need to build the reTerminal drivers:

  1. sudo apt install raspberrypi-kernel-headers git
  2. git clone --depth 1
  3. cd seeed-linux-dtoverlays
  4. sudo ./scripts/
  5. Reboot

Now, I couldn’t get this to work, but you might have better luck. Otherwise, just use the Seeed Studio version, which already has the drivers.

Lastly, many folks had issues after updating - if you can get yourselves into a good state where’s it’s working first, then move forward with getting the package updates working.


1 Like

Hi @glaeken - thanks for your reply.

Indeed, I just found that I had to do that .

I’ll let you know if it worked.

Driver install fails for me too on Ubuntu:

### Install required kernel package
Reading package lists... Done
Building dependency tree
Reading state information... Done
W: --force-yes is deprecated, use one of the options starting with --allow instead.

E: Unable to locate package raspberrypi-kernel-headers
E: Unable to locate package raspberrypi-kernel
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-headers-raspi is already the newest version (
linux-headers-raspi set to manually installed.
linux-image-raspi is already the newest version (
linux-image-raspi set to manually installed.
linux-raspi is already the newest version (
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
KBUILD: /lib/modules/5.4.0-1041-raspi/build

Creating symlink /var/lib/dkms/mipi_dsi/0.1/source ->

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j4 KERNELRELEASE=5.4.0-1041-raspi all KVERSION=5.4.0-1041-raspi....(bad exit status: 2)
ERROR (dkms apport): binary package for mipi_dsi: 0.1 not found
Error! Bad return status for module build on kernel: 5.4.0-1041-raspi (aarch64)
Consult /var/lib/dkms/mipi_dsi/0.1/build/make.log for more information.
Can't compile with this kernel, aborting
Please try to compile with the option --compat-kernel

Seems I’ll go for Seeed’s OS release :smiley:

I think I found a solution - make sure that reTerminal has an internet connection and that either SSH is setup or you have the means to connect to the UART console.

After upgrading and rebooting, the screen will stay blank, yet the OS should be up. Now connect to the console via SSH or UART and reinstall the drivers as outlined here.

The screen should work again after a subsequent reboot. (although I have to say it seems I have a flickering ribbon on the screen now - not sure where it comes from).

I assume that the firmware or kernel upgrade somehow messes with the configuration done by the driver install.

Hope this helps - and hope that this issue gets resolved in the future.


Yes, that works. So the first automatic upgrade, over which the user has no control, will clobber the drivers. Do I detect traces of egg in Seed Studios face? Anyway, thank you Icnittl.

[quote=“glaeken, post:4, topic:259833”]
Subsequent attempts to boot have both PWR and SYS light illuminated, and the heat sink will again get very hot, so something is happening. No lights on the ETH port, even when connected to a network.

I’ve done some digging around to see if it might be the rpi or the host board that might be the issue. Even after imaging the eMMC (so we kind of know the CM4 still works), I still can’t get any output from the screen. I’ve attempted installing RISC OS and RaspberryPi OS (latest).


Dracaena Reflexa.

1 Like

Same issue here… New reTerminal successfully boots out of the box, goes through an initial setup process that includes: localization, setting up a new password, setting up the network (WiFi), and guides you to upgrade.

After reboot… Blank screen.

I was able to ssh in, needed to install git…

sudo apt install git-all

Download the drivers…

git clone --depth 1

cd to the directory…

cd seeed-linux-dtoverlays

Rebuild the drivers…

sudo ./scripts/

And, and reboot…

sudo reboot

reTerminal screen came back, but it’s rotated -90 degrees and requires login…

Suggestions on how to correct the rotation, and re-allow auto login on the console?

1 Like

Looks like I started a long thread here.

Everyone good luck fixing this issue. I had hoped to use these on a product we’re rolling out. I ordered one and it is a complete disappointment. Shifting my initial 200 units to something that works from a company that cares.

Anyone who wants my brand new screen doesn’t work shitTerminal… $50 and its yours, message me.

Had same issue, and recommend fix worked. Not sure how something like this got pass QA testing?

Are you shipping products using the default distribution from the manufactures? Please don’t do this, this is how botnets are created. And don’t use the RPi standard image either. The reTerminal is about the hardware. You’re expected to re-spin / create your own distribution. Yes it’s a shame that this has happened, mine had the same issue and I just received it. So not been fixed in the last month. But I always planned to be using my own distribution that has been tailored for the customers requirements.

1 Like

Hello everyone,

We apologize for any inconvenience caused after updating the reTerminal for the very first time. There was a major problem of the LCD not working after doing an update through the initial configuration window. However, if you have checked the wiki carefully, I have mentioned under Step 9 inside Quick Start with reTerminal that you need to skip this step and update the reTerminal through command line separately. Otherwise, if you directly update from this configuration screen and reboot, all the drivers will not load again properly, causing the LCD to not work.

However, I understand that most people, when they buy the reTerminal, they just power on, and will go through the initial configuration screen just as they would with a Raspberry Pi without checking any manual.

So now we have fixed this bug from the Raspberry Pi OS factory image and you can find the latest images here. Please flash the OS using this wiki, and then you can update the reTerminal as usual.

Also, we will ship our latest reTerminals with this image already pre-installed. In that way, future customers will not face this issue.

We hope you understand this matter and hope to see you all doing great projects with reTerminal!

I welcome you all to join our Discord as well and ask any reTerminal related question in the cm4-related product channel. If you have questions for other Seeed products, you can choose a different channel.

1 Like

Thanks for the link to Jeff Geerling’s blog.

I did the same thing to my reTerminal when I first powered it on: tried to do the update before I saw the warning not to.

I used Jeff’s procedure to get usbboot to mount the eMMC and am now waiting for rpi-imager to flash /

I’m excited to get into development on the reTerminal.

Hallo everyone,
I had the same problem with the screen black out, SSH and the RS232 connection did not work. Then I followed lakshan’s advice, downloaded the special images (32/64 bit version, see Question 2 of FAQ of the reTerminal Introduction web site) and wrote the 64 version to the eMMC. It worked and the screen is back now. Thank you!

1 Like

I was able to get past the blank screen issue by re-imaging the reTerminal with the seeed image as described. However, now I’m unable to use the buttons, led, or buzzer in Python. It seems that these devices don’t exist as files in the linux filesystem. Whenever I try to utilize one of them, I get:

No such file or directory: '/sys/class/leds/usr_led2/brightness'

I checked the folder /sys/class/leds, and there is in fact no usr_led2 (or anything similar) present. Any ideas how to get these devices back?

Hello @ScottCLT,

Do you mean when you use the seeed-python-reterminal library?

Did you first test with “evtest” tool?

Also, please attach the output of “i2cdetect -y 1”. It will help me to check the issue further.

Best Regards,

Thanks for the reply. Yes, I am trying to use the seeed-python-reterminal library.

I was unfamiliar with evtest, but I installed it and this is the output:

No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:	Riitek Micro Keyboard Mouse
/dev/input/event1:	Riitek Micro Keyboard
/dev/input/event2:	seeed-tp
/dev/input/event3:	Riitek Micro Keyboard Consumer Control
/dev/input/event4:	vc4
/dev/input/event5:	ST LIS3LV02DL Accelerometer
/dev/input/event6:	vc4
Select the device event number [0-6]:

I did not see the device to test, so I did not proceed.

I also ran i2cdetect -y 1. Here is the output of that:

     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 
10: -- -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- 
20: -- -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- 
30: -- -- -- -- -- -- -- -- 38 -- -- -- -- -- -- -- 
40: -- -- -- -- -- UU -- -- -- -- -- -- -- -- -- -- 
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
70: -- -- -- -- -- -- -- --                         

Sorry, I have no idea what I’m looking at in those results! :slight_smile:

Hello @ScottCLT,

Let me make it clear for you about the debugging.

From the i2cdetect command, we can check whether the drivers for the inbuilt hardware has been properly loaded:

i2cdetect -y 1

  • 0x19 - accelerometer
  • 0x29 - light sensor
  • 0x38 - IO-extender - buzzer, LEDs and buttons
  • 0x45 - LCD

i2cdetect -y 3

  • 0x51 - RTC
  • 0x60 - Encryption processor

However, if the drivers are loaded, you should see UU instead of the I2C address.

But in your output above, 0x38 is not loaded which means the drivers for buzzer, LEDs and buttons are not loaded. This is quite unusual.

Could you please reflash with the below image and try again?

Try the 32-bit at first.

Best Regards,

1 Like

I bought one in November 2021 and it still has this problem.
Unfortunately the wiki instructions don’t work for me due to rpiboot issue:

Not sure where to go from here. Love the design. When can I safely buy one that works?