New firmware :DS0201_V2.2X

I see that the firmware on the Google Code page is “App v2.31” – I assume that this is newer than the v2.2x series. I have 2.01 installed, do I have to upgrade first to 2.2x and then 2.31 or can I just right to the newest firmware? Thanks for your help.

When upgrade to v2.31, the DSO interface reads as v2.02. Now I’m not sure either I have upgrade to v2.31 while having the interface read as v2.02 or it’s not upgrading at all and stays at v2.02.

You would need to upload DS0201_LIB_V2.21.dfu first, then APP.

I did but it only worked with v2.21 but not 2.31. I can’t find LIB file for 2.31.
If the APP file needs the LIB file, I suggest both files to be included in a folder.
As you can see, Paul’s 1.5 is also not accompanied by it’s LIB file. I tried upgrading
to that file too and nothing happened. In the firmware upgrade manual, there’s nothing
mentioning about the LIB file accompaniment. I think that is just misleading. Upgrading
the firmware is not as simple as I first thought it should be.

2.31 APP uses 2.21 LIB, I have consolidated to a new zip file. Check it out here: … p&can=2&q=

Also upgraded the manual. Sorry for the confusion, but simple in fact. :slight_smile:

Thank you very much ESP. Those files work.

So, what was wrong with my previous way of flashing?
Exactly the same procedure but it never grab the firmware.
Weird eh? So, now off to try taking some pattern with it.

Not sure about the details on your end, maybe some operation overlooked? Glad to know those are working, let us know if any more questions. Thanks!

I downloaded the file on google code, but it contains two files DSO201_APP_V2.21.dfu and DSO201_APP_V2.31.dfu. Is the first file the correct LIB file ?

scroll up a bit, ESP just answered that.

2.31 APP uses 2.21 dfu.

The filename in the zip archive is DSO201_APP_V2.21.dfu not DS0201_LIB_V2.21.dfu though. So do you install APP_V2.21 first followed by APP_V2.31 ?


That won’t help because it is two versions of the APP file and no LIB file :frowning:

I tried the LIB file from the first post in this thread which contains APP 2.21, it also contains a LIB file and it seems to work, atleast the nano says LIB 2.21 on startup now.

Kind regards

Upload both files one after the other without resetting the DSO in the process. That was how I did mine.

The sequence does not matter, I wrapped them both here: …


ESP, please read nst and my post more carefully, your zipfile does not contain a LIB file but two different APP files.

here you have it.
DS0201_LIB_V2.21.rar (21.8 KB)

Sorry for my mistake, here is the one with right “LIB” …

I just received my DSO nano which comes with firmware 2.02.
Because I want to change it a little bit I started searching for the source files.
However I couldn’t find them, so my question is if anyone is willing to upload the source files for FW2.02.

Thanks in advance.

Hi, I upload the file DSO original, previous posted, but… I don’like seedstudio logo, and couldn’t back firmware… Some one have a complete firmware (logo e-designs). Original me are 1,4.

I tried 2,02,2.31,1.5 but nevers change logo and only likes paul (is more easy to manage).