New firmware :DS0201_V2.2X

Hi @all!


in short: JTAG is a direct connection to the processor, for debugging, monitoring, programming…

If anything goes wrong while flashing the backup file i posted (power loss,…) or it´s simply not compatible to your hardware revision (i think it wold work for all revisions but I DON´T KNOW…) it may be possible that your dso would not start anymore and you won´t be able to flash a new firmware the normal way.

in such a case you could use a jtag interface cable and a piece of software to access the processor directly and so programm it´s internal memory.

I think if if your battery is full, usb cable and power switch stays untouched during flash, the risc is minimal.
but that minimal risc is yours :wink:


did a bit of research on JTAG and though I feel technically qualified to use the JTAG programmer I think I can deal with this firmware untill Seeed Studio decides to post the previous rev. I feel like an idiot for not backing it up. I just figured they would have it somewhere.

Maybe I’ll just buy this from sparkfun and do it anyway.: … cts_id=275

seems cheap enough and the DSO already has some breakout connections for programming it looks like.

If anything “flickers” it probably a sign that more is redrawn on the screen then it should/needed and it might be CPU intensive/draw battery. If my suspicions are correct then its bad but it also means the nano has room for improvements and can get even faster when optimised :slight_smile:

What’s the timeplan for the final 2.2 release?

I agree with the transparent stuff, it just makes the traces harder to see.

The Xposition is backwards, lock on to a square wave and select the T0,
as you press the left/right the trigger marker moves the way you select, but
the square wave moves the wrong direction. The right amount, just the wrong way.


its here:

I’m having the same problems as Ben. Triggers don’t work apart from in AUTO mode. NORM and SIGN/SING mostly don’t display the triggered signal at all.

Sometimes in NORM mode, when the R/S button is pressed and HOLD is displayed on the screen, I can see the waveform moving.

Sometimes it does trigger, but only after HOLDing, and possibly only after holding while the signal level is low if you’re looking for a rising edge. It appears to work better at longer time bases.

SIGN mode doesn’t work at all for me, unless I press the R/S button and immediately get a trigger. Could it be that these are triggering further along the horizontal axis and are therefore out of view?

I’m using firmware version 2.21. To test SIGN and NORM modes I was manually triggering the signal level rather than putting a waveform through it.

Hope that helps, and I look forward to the next update!

When will be released approximately the next firmware for DSO Nano? What’s your milestone?

I’ve been trying to load the firmware on the nano for a while, but it simply does not show itself as a USB device for me… :frowning:

I’ve tried it on a macbook (W7pro x64 and snow leo) and on a compaq notebook with WXP pro, and the device simply does not register… The screen on the DSO does show “USB” instead of the battery, but DfuSe shows nothing, either…

I’ve also tried holding Down while turning it on. The “Please connect to USB Host” screen appears, but plugging the USB cable yields nothing…

So, any guesses? My DSO is from the first batch, from last year…


Guys, sorry for idling. We will get back to the firmware upgrade soon, will keep you guys posted! Thanks for all the suggestions :slight_smile:

I see that the firmware on the Google Code page is “App v2.31” – I assume that this is newer than the v2.2x series. I have 2.01 installed, do I have to upgrade first to 2.2x and then 2.31 or can I just right to the newest firmware? Thanks for your help.

When upgrade to v2.31, the DSO interface reads as v2.02. Now I’m not sure either I have upgrade to v2.31 while having the interface read as v2.02 or it’s not upgrading at all and stays at v2.02.

You would need to upload DS0201_LIB_V2.21.dfu first, then APP.

I did but it only worked with v2.21 but not 2.31. I can’t find LIB file for 2.31.
If the APP file needs the LIB file, I suggest both files to be included in a folder.
As you can see, Paul’s 1.5 is also not accompanied by it’s LIB file. I tried upgrading
to that file too and nothing happened. In the firmware upgrade manual, there’s nothing
mentioning about the LIB file accompaniment. I think that is just misleading. Upgrading
the firmware is not as simple as I first thought it should be.

2.31 APP uses 2.21 LIB, I have consolidated to a new zip file. Check it out here: … p&can=2&q=

Also upgraded the manual. Sorry for the confusion, but simple in fact. :slight_smile:

Thank you very much ESP. Those files work.

So, what was wrong with my previous way of flashing?
Exactly the same procedure but it never grab the firmware.
Weird eh? So, now off to try taking some pattern with it.

Not sure about the details on your end, maybe some operation overlooked? Glad to know those are working, let us know if any more questions. Thanks!

I downloaded the file on google code, but it contains two files DSO201_APP_V2.21.dfu and DSO201_APP_V2.31.dfu. Is the first file the correct LIB file ?

scroll up a bit, ESP just answered that.

2.31 APP uses 2.21 dfu.

The filename in the zip archive is DSO201_APP_V2.21.dfu not DS0201_LIB_V2.21.dfu though. So do you install APP_V2.21 first followed by APP_V2.31 ?


That won’t help because it is two versions of the APP file and no LIB file :frowning:

I tried the LIB file from the first post in this thread which contains APP 2.21, it also contains a LIB file and it seems to work, atleast the nano says LIB 2.21 on startup now.

Kind regards