New dso quad, need help with frquency/duty cycle

New to the forums and the dso quad, calibration as far as the caps are concerned are spot on, DC offset is decently off, but ill calibrate that when I get to an adjustable power supply at school.

Anyways, my problem is that no matter what signal I try to measure (including from the generator), it doesn’t ever show the signals frequency, duty cycle, or triggering times, trigger points are all setup properly I believe, wont show frequency of ANYTHING. Is there something I’m doing wrong?

Alright so I took a video of what I’m talking about and some other bugs I think I noted
youtube watch?v=IzpYL-W9FoM

sorry but I couldn’t make it a link do to being new >…>

Depending on the app you are running it may be that you need to set the two time cursors to the start and end of a cycle. The display will then show the time difference and calculate the frequency.

There are four channels, and each has a color

Ch_A Blue
Ch_B Yellow
Ch_C Red
Ch_D Green

Button 3, the one with the dot symbol, toggles the little popup window.
The items you see there can be changed. Try to press and HOLD
button 3. A narrower window comes up showing the selected
items. Note that FRQ is shown in red. What could that mean?
Right, it is the frequency of the C channel. Move the < > switch to
the right to select the FRQ item. Now Move the + - switch and observe
that it loops thru all available parameters. Make it show FRQ again,
then press + - down. This selects the color = channel. Set it to BLUE.
Press < > to close the window. Apply a periodic signal to Ch_A, set
the trigger for a stable display and press button 3 again.
FRQ should now show the frequency.


That absolutely worked, thank you very much for that.
Now, I also seem to have a problem with the displayed voltage going up with the scale as well with no actual input, also shown in video
and what’s the easiest way to calibrate without an already adjustable voltage source

Mine does the same. I am thru the calibration ordeal three times and the readings are a bit closer to reality now but that’s it. Even with the inputs to GND I get readings of up to 1 Volt, depending on range. If you have the new HW v2.72 be very careful not to exceed an input voltage of 25V. Some cal message says apply 50 to 60V. DONT! I used 20V as with the next lower range. I used a power supply and a good DVM as reference.

Please note that I am not an expert in any way as I have this gadget for less than a week now. Unfortunately the Community App and the Wildcat version don’t work an this HW version (yet?), so I am stuck with the v1.10 stock firmware.

Have you tried the Gabonator FW?