Neorainbowduino i2c communication help.

Hello all.
I have just gotten neorainbowduino uploaded and can’t seem to figure out why I can’t get any i2c communication.
I’m quite new to this so I’m not sure where to start.

I have a arduino mega 2560 and a rainbowduino v2.0
I used the “neorainbow-0.82” package and followed the install steps from here:

When I run an example sketch in processing nothing new is displayed on the matrix. I just have the neorainbowduino space invader image.
When I run the i2c scanner example it returns nothing.

I have been over my wire connections, checked the libraries are patched and installed correctly. I’m not sure what else to do?
I have already tried loading the firmwares again.


OK, well the very helpful mich from helped me out via email and suggested I look at the mega’s i2c pins. Sure enough they needed switching and now I have got communication!

However I still have some problems.
The i2c scanner example finds my board now, the simple example produces dots everywhere. I can’t get the invaders demo to display on my matrix though. It is running in processing but no output on the matrix.
When I run the simple example I get the message:

Last Timestamp at 7 Mar 2011 13:35:38 GMT Arduino Serial Buffer Size: 0 last arduino error: 2 I get this every 2-3 seconds over and over. Then after a while I start getting these errors:

08/03/2011 12:36:00 AM com.neophob.lib.rainbowduino.Rainbowduino waitForAck INFO: No serial reply, duration: 30ms

Any ideas?