Need help - Nano v2 not seen by Win7/64 PC

Hi everyone, I’ve been fussing with this device for too many hours, I’m about to toss it, you are my last hope! I’ve read about everything there is on loading the latest Benf firmware and think that this device is defective or the USB port is dead on it. After loading the latest software, booting the Nano in loading mode, I connect it to the PC (any pc) and no beep, no asking for drivers, nothing. What can I do at this point? I see how it is supposed to work, it’s just not.
Thanks in advance.

If you’ve tried multiple computers with different usb cables(short/long) and none of them recognize that you plugged in a “new” usb device then I believe your DSO Nano is at fault.

Does the computer charges the Nano by showing USB on Nano display?

Hi, thanks for your reply. This is what I have been thinking too, since it does nothing on any computer. I need to know if it can be replaced and where to go for that sort of help. I bought this in January and never used it since I couldn’t get the upgraded firmware loaded. Just got some time so I’m trying to resolve it, I’d really like to use it!

There is little that could fail in USB circuit. You should check R22, R23, R24. Check for shorts. Check for opens on D- and D+ and STM32. Check for 3V to the right of R24. Check if the connector pins bent. If all checks out, then its the STM32.

Look at … f&can=2&q=

I appreciate your time trying to help me, but I’m not inclined to open a new device to test it. 2 reasons, I feel it should be covered under warranty, and I’m not that experienced with board level diagnostics. Do you know who I can contact about a replacement?

If you ordered from Seeed directly then contact QC. If no answer, I got Kevin engineer email that helped me greatly. Else, contact your supplier.

Quality Issue:

If you got a defect, please email: We will do our best to locate the cause and work out a satisfying solution ASAP.

Hi, sorry for the delay. I emailed QC, hope they can help. I just tried again, yes the USB display appears but no further action.

Right. The USB on the Nano display means that its sensing the computers USB power. The computer looks at Data lines to detect a new device. I hope you get a replacement.