Need 64-Bit, Windows 10 Drivers

I’m running out of steam here.

I keep plugging in different Xiao’s and they keep coming up as unknown device. I’ve looked everywhere for 64-bit USB drivers. The signed drivers from here: https://github.com/Seeed-Studio/Signed_USB_Serial_Driver/archive/master.zip

Are 32-Bit and my Windows 10 won’t let me use them.

My windows device manager specifically lists it as “Unknown USB Device (Device Descriptor Request Failed)”.

Device USB\VID_0000&PID_0002\5&3d4f2f0&0&5 had a problem starting.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Service:
Lower Filters:
Upper Filters:
Problem: 0x2B
Problem Status: 0x0

Device USB\VID_0000&PID_0002\5&3d4f2f0&0&5 was configured.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.19041.488
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\ROOT_HUB30\4&19efecd6&0&0

Device USB\VID_0000&PID_0002\5&3d4f2f0&0&5 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USB\VID_05CA&PID_0365\03000200000004030000000000000000
Class Guid: {eec5ad98-8080-425f-922a-dabf3de3f69a}
Location Path: ACPI(SB)#ACPI(PCI0)#ACPI(XHC_)#ACPI(RHUB)#ACPI(HS05)
Migration Rank: 0xF000FFFFFFFF0033
Present: false
Status: 0xC0000719

I’ve also tried generic Arduino drivers, they don’t work. I’ve tried the FTDI USB Drivers, they don’t work either.