Navigation Joy-stick

What is the use for the central button in the Navigation joy-stick?
How can I clear the memorized wave-form when set on the DSO the first time?
There are a few things that the manual do not refere, do you think also?
Thanks for coments.

about the navigation joy-stick action is all in Manual .

Means that the middle button has no function, as it is not described in the manual?

And how about the second question:
How can I clear the memorized wave-form when set on the DSO the first time?
This is what I am interested in either!

Best Regards


Yeah, the middle button doesn’t do anything.

To clear the initial waveform, just make a change to the vertical or horizontal scaling. As described in the manual, the wave will disappear because the selected scaling is different to the scaling of the saved waveform.

I think the device should try to scale the waveform to the currently selected scaling and have a separate option to turn it off though…

Yeah, but how to erase it permanently?

Solved the problem in the meantime by flashing a new 3rd party firmware :unamused:
Not only this issue disappeared, but also the useabilty of the interface is much more user friendly in my opinion. I found it in the depth of the internet in a chinese forum. It is from a user named yijian and has a Tek like UI.

Best Regards


On this page, post 88?

Looks good - I’ll have to try it!

Exact :smiley: (Your link was not visible, so I edited the quote a bit!)

Here is a picture of the UI:

Yijian Firmware.jpg

I tried it out - it looks really good and the control system makes more sense than the proper firmware, although the battery level still seems inaccurate.

I’m reverting to the original firmware. This one can’t do the following:

Normal mode doesn’t work - it just doesn’t look like it trigers. SAME WITH Signal mode. It also can’t scan.

There are pixels left behind all over the place.

It can’t display the current average voltage, and other measurements.

Other than that, the control system is much better than the Seeedstudio firmware.

Try the “Paul” firmware - it’s available from here and/or the Chinese language blog, the latest version I’ve seen is this:


On the Chinese language page, Paul says he’s not doing further development, somebody who can write Chinese should ask him to release his source code - I think this version is the most all-around usable of everything that’s available.

Awesome! You’re right - that’s by far the best one so far! Thanks very much!

Can someone please ask him for his source code?