Nano v3 white screen no DFU mode

I was trying to upgrade the firmware with my Mac when I noticed I was only getting a white screen when I powered it on. I tried to enter DFU mode but I see the same white screen. When I plug it into a Windows machine I see a popup “USB Device Not Recognized”. Note sure where to go from here, did I brick it? Anyway other way to force it into DFU mode?

I hooked up FTDI cable to CN4 and tried to load several different firmware versions, they all load successfully but I still have a white screen and no dfu mode. Anyone have any ideas?

Ok, I got it.

I brought out my FTDI ( … After I restarted the device my DSO Nano showed up as drive on Windows.

Same problem anybody proper solution.

I had the same problem while trying to upgrade to BenF 364. Here’s how I solved the problem:

Reading “FAQ: How to upgrade the firmware” I found the following:

I checked and sure enough I was running 3.30D so I followed the link that lead me to this file (which apparently addresses the different display in this version of NANO3). I copied the file my unit and all is well again.