Nano refuses to be seen by XP

Hey guys,

Wow I dont want to vent regarding registration, but the capcha gotta go!

Anyways, I have tried every possible way to get XP to see my nano, I was able to solve the sd card errors thanks to the users here and I dont have an issue using a external card to read the files.

My issue is XP will not see my nano in any way, shape or form. I tried 3 different machines and non of them see the nano as any form of hardware device, nor does New hardware Wizard, or a single hard drive blip indicate it has been plugged into USB. My concern is as firmwares are introduced, I am stuck here. I followed the procedure to put the unit into DFU mode, and it just sits there forever saying “connect to usb host” At this point, Im just at the point of Grrr… any suggestions?

  • Jay

That may be a design mistake of DSO USB port. we use the 18K trigger resistance for it and in 30 pes beta we found some computer can’t see it …
In these 100 pes we have change the resistance to 1.8K and the issue should be fixed , please do me a favor to check the R24 in the board , is it a 1.8k resistance (182).


Thanks for the infomation,

Without applying excessive force, I am experiencing a bit of a fight on the corner where the output pin is at the switch. It feels like there
is a screw holding it together from the display side. but without breaking the front lcd cover since its stuck on there pretty good to check, I will just wait for your reply to proceed. Based on what your saying, it sure sounds like I ended up with one that had an incorrect value.

I can get the halves apart without any problem with a case splitter right to that point, and right at that corner its locked down pretty solidly.

  • Jay

the fastest way is to fix it by your self~
you can take apart the outer covering with any way include destroy it , and we will sent you a new covering.

check the R24 and tell us is it a 182(1.8K) resistance , if not that it’s easy to fix it , just use a 1.8K to replace it ~ if you cann’t fine a 1.8K resistance then we will sent you some with the covering.

if you cann’t replace the resistance , then just has a slower way : ship it back to us and we will Repair it for you.

Of cause , let’s make sure the issue first , check the resistance yourself at first , then work about it later.

HI! my DSO arrived yesterday ( 6 days to arrive Greece with register mail!)
I have problems too connecting DSO to winxp . I have tried different PCs and problem persists ‘Unknown device USB’ message .

Open back cover and broken it (actually I see a screw under front panel ,afterwards!)

Checked the R24 value with a multimeter and it reads 1.4k I think it’s ok or maybe a diffective resistor? ( also the code read 182 so its the right one)

any idea?

Thank you for your time

NOTE: If you don’t want to crack the screw base there is a hidden screw beneath front cover near the ‘M’ down right side!

if show Unknown device USB that mean the PC can trigger by the DSO , not the same as printerpro, his DSO can not trigger the PC usb even to let the PC see it.

why the PC can not recognize your DSO and see it as unknown device , that may be two reason :
1 you have not installed a STM32 driver in your PC
2 the D2 ESD IC is broken , and it connect the D- D+ to GND so the PC can not Communicate with DSO , but the PC see the DSO so it consider it as a unknown device. if you sure you have installed the driver for DSO then you can remove the D2 from your broad to try again …


I’m lost here…

mass storage drivers aren’t required in all mainstream OSs i know: windows (>2000), OSX, linux.

why sould we install a STM32 USB driver??

P.S. My Nano also appeared as unknown device in XP (tested in several PCs) and in some cases reported a uSD of 3.7GB (uSD was the one which came with the Nano)

the DSO not just a mass storage device , but more a STM Device in DFU mode :


we suggest Don’t use the DSO as a mass storage device , because the firmware is not support it well. but you need to install a STM32 driver that make sure you can use it as a STM Device in DFU Mode , so you can upgrade the new firmware by the USB.


You were ABSOLUTELY right!
There was a faulty D2. Removed and everything is working now!
FreeZinG is D2 for ESD purposes? Has it to be replaced?

Note: In order to remove D2 you must have access to the second PCB (with mini usb plug).
You have to unsolder 4 pins near the usb plug and two other pins on the other side.

BE CAREFULL not to heat too much as you can easily destroy tinny pads! (guess how I know it :blush: ) I managed to destroy one of the usb Data lines BUT I repaired soldering a tiny wire from R22 to mini usb pin.
I am happy DSO is working again!
Thank you for your advice FreeZinG

also: As I am going to try out the 3rd party fw by Paul, in case I want to revert back to original file , could we have the fw 2.01 comes with dso ,please?

Here is the newest F/W for DSO :
DS0201_FW_V2.02_SS.rar (20 KB)

BTW, the D2 is a ESD protect diode, there are many model ESD diode of 5V , you can choose some similar parameter to replace it . and here is the datasheet of D2 :
CESD5V0AP.rar (290 KB)

Where can I download the STM32 driver ??

I am running windows 7 and it keeps connecting the DSO and then disconnecting it.

you can download a DfuSe software , and install it then a driver will be installed ,too .

here is the driver file i copy from the DfuSe folder, you can try to renew the driver . But i still suggest you had better to download a Dfuse , because you must use it to update your firmware.
Driver.rar (22.9 KB)