Nano 1 and my BenF Install

Hi, a total beginner here and I’ve fallen at the first hurdle. I’ve just purchased a DSO Nano1 to do a very simple check on my Meade telescope drive system. It’s controlled via a square wave output loop that controls the motors. Anyway, the Nano worked perfectly out of the box. That is, it produced the default wavy trace when switched on. Looked perfect for my purpose. So, before anything else, I decided to install the BenF firmware as generally recommended on the Internet. It’s reckoned to be easier to understand, which is exactly what I need.

I downloaded the software from this very forum and followed the routine. Nano to pc with USB cable. Hold down the ‘minus’ button and power up the Nano. Screen asked for .hex or .bin files to be loaded into root directory. This went fine and each in turn displayed as a .rdy file. Powered off the Nano.

On powering up again, there’s a jittery white screen with a vague sort of logo ‘digital storage oscilloscope’ displayed in mirror image text. Nothing else. No Ben for sure.

I’ve repeated this several times without success. The file transfer sometimes pops a message that the Nano folder is no longer present, or the file’s too large for the destination and such wierd stuff. I tried to go back to square one by downloaading the DSO firmware but can’t get this to run either.

Where am I going wrong?


If its the new nano with new boot loader than check this out


The new nano wouldn’t work with ben f but these guys figured it out the link is right to page were the new downloads are but I recommend reading the whole post

The BenF Patch was applied and the Nano now runs fine.
I’m most grateful for your help, much appreciated.