MW0582TR11 Not Working...

I’ve received my MW0582TR11 and can’t seem to get it to respond to any commands. I’ve tried using Teraterm, mw0582_gui.py, and SerialMon with no response from the unit. I’ve verified that the unit is powered with 5VDC and I’m using a USB to serial port adaptor (TTL level signals). I’ve even tied the USB to serial adaptor TX and RX together to make sure that it loops back all the commands. I thought maybe I had the TX/RX switched but that didn’t have any impact on the unit. There seems to be a descrepency in the baudrate that should be used. The website and the Python example uses a baudrate of 512000 (which seems to be a non standard rate because no app supports this rate) but the MW0582TR11 datasheet calls out 19200. What baudrate should I be using? It almost seems the PDF provided is old or for a different product as the pinouts of the actual product don’t match the PDF.

Hi,



Can you share the product details?

Here are pictures of the of the unit I received. These are different than the manual which seems to be an earlier rev. In looking at the Python example app I don’t see anywhere in the code where the MW0582TR11 is commanded to start sending data. Does it just boot up and start dumping data automatically?
1231190840a.jpg
1231190840.jpg

I’ve tried a second unit and I get the same results! Nothing is working!

I’ve finally gotten the unit to at least send data and respond OK to the AT+DEBUG=x commands. I was powering up the unit by inserting a USB to serial adaptor that would power the unit and I never saw the bootup data. The unit doesn’t really do anything except boot and show the current settings. I’ve tried several of the commands in the Python demo app under Teraterm. Supposedly one should be able to issue the command AT+DEBUG=2 to get the unit to start spewing data, but that doesn’t work. What is the complete list of AT commands? How does one get the unit to start to send data?
MW_BootScreen.PNG

Hi,



Did you tried the SDK (https://github.com/maxusdev/mwtool) listed on Github . and what problem are you facing when using the SDK?



Happy new year :tada:

Yes, I have downloaded the latest SDK from Git. The problem I’m having right now is that there isn’t any data being sent by the unit when it is powered up. I get the screen of default settings but the unit will not send any data. The SDK app doesn’t contain any commands that start the sending of data. There are commands to change the settings, but that is it. So I’m ASSUMING that the unit will automatically start sending data since there aren’t any commands to do so. I would like to get a full list of commands that this unit responds too beyond that what is listed in the Read.me file or the app.

Hi,



Which one did you use Python or Node and the GUI or CLI version?



Currently, they provided Debug commands listed below

[list]

  • Radiated PowerAT+PA=x with x ranges from 0~7 (default is 1)
  • [/list]
    [list]
  • RX Gain AT+REVGAIN=x with x ranges from 0~7 (default is 7)
  • [/list]

    [list]

  • Time delay after detection AT+DELAY=xxxx with xxxx ranges from 0001~3599 (default is 0002, unit is second)
  • [/list]

    [list]

  • Mode selection AT+DEBUG=x Normal mode when x = 0 (default); Raw data mode when x = 2
  • [/list]

    [list]

  • Detect Threshold AT+THRES=xx with xx ranges from 01~99 (default is 12)
  • [/list]

    Source : https://github.com/MaxusDev/MWTool

    Well right now I’m using Teraterm to send the commands and read the responses. This is working fine. But the unit doesn’t send data. Even tried the AT+DEBUG=2 thinking that will start the unit sending data but it doesn’t. I’ve tried this on two different units and they both behave the same way: no data.

    So I take it I’ve got everyone stumped on this one eh? Well I guess I’ll have to return the units as no one has an answer.

    Hi,



    what you meant by

    ?

    I bought two of the units and both cannot communicate on serial.

    I tried everything and i cannot get these devices to work. I am a developer and electronic engineer and these devices are either defective or the documentation is wrong.
    I followed the provided info on github. IT DOES NOT WORK
    Can any please assist?

    Command for debug => AT+DEBUG=0002 Does anyone now how to change serial baud rate?

    The baud rate it fixed and there isn’t any way to change it…