Multiple XIAO ESP32C3 boards only give Write Timeout error when uploading


I am new to this forum and also micro-controllers and the like. Over the past month I have been experimenting with XIAO ESP32C3 boards and have noticed a problem with all of them. The first time I connect it and upload code (even example projects) from Arduino IDE, everything works great. Later on, the output console informs me that I need to put the ESP in download mode. Fair enough, I do that and it works. A couple more uploads later, I get a “Write Timeout” error:

A serial exception error occurred: Write timeout
Note: This error originates from pySerial. It is likely not a problem with esptool, but with the hardware connection or drivers.
For troubleshooting steps visit:

This error is persistent and this process has occurred across four different XIAO ESP32C3 boards.

When researching solutions in forums and blogs, I would see things like trying different USB cables, different USB ports, downloading drivers, playing around with the bootloader mode, pressing the boot button when it is connecting, and flashing the device with ESPrfTestTool. I have also gone through the steps listed in the official FAQ. None of these solutions have worked for me thus far. It always reaches the “Connecting…” stage, and then spits out the error above.

I think it might be important to note that when I simply connect the board, I get this notification from Windows:
But when I connect it while holding the boot button, I that notification is not present and I am able to see the COM Port come up. I don’t remember shorting any connections, if that is what caused the issue.

I would really love to use this board for some of my projects, but seeing as I can’t figure out how to actually upload the code, I don’t think I will stick with it much longer. Any help is appreciated.

Since no troubleshooting suggestion is working, I think seeedstudio should perform some tests with these boards. Hope they will find and suggest a solution.

By the way, if you ever consider making a customized ESP32 board by yourself, you can follow this design: Make your own branded ESP32 development board with PCBWay! - Share Project - PCBWay

It’s kind of embarrassing, but I found the solution, I think. I used a probe to press the boot button this time and it worked. When I tried with my finger, the same issue happened. I guess I just have fat fingers or something? Either way, it works now.

Oh. Good to know that it worked and there is no design error/bug in these boards.