MR60BHA1 Windows App QT5Chart.dll missing

I’ve downloaded the MR60BHA1_new.exe file as linked to from the MR60BHA1 web page. When I run it I get an error message initially that it cannot find some entry point in QT5Charts.dll and then an error that it cannot open QT5Charts.dll.
I downloaded QT5 but the error messages stayed the same.
I then did a Google search for the “QT5Charts.dll not found” error which led me to a file that I could download and add to the same folder as the exe file.
Still the same error message.
I’ve also tried running as administrator with no success.
My configuration is the Windows 11 Pro insider preview ARM64 under Parallels on mu iMac M1.
And before anyone goes on about the fact it is ARM64 windows, it is definitely running the exe as an ‘x64’ app. I’ve had many other x64 apps run successfully in this configuration.

The latest version of what?
Windows is completely up to date (as is Parallels but that has notching to do with this). I installed Qt5 when I started to get the error messages. I downloaded your program2 days ago.

I assume that you have deleted the reply that was sent to me via email (which was all about updating to the latest firmware). I will try that but I don’t see how that relates to your windows app not finding Qt5 on the Windows system. (Presumably that is why you deleted the above replies)

Sorry, my colleague may not have understood what you have expressed.
The upper computer software that comes with the radar is made by our embedded engineers, and the original purpose is to let some customers who have no code base to quickly get started to check the radar’s data information or installation and debugging. However, they are not professional software engineers, so they do not have a good testing environment or the ability to solve different environmental problems. We can only make sure the software can run the software normally in Windows on x86 devices.
As for the Parallels VM you installed on your mac, we still think that it might be a problem with the Windows environment of the VM, and if possible, we still hope that if you want to use the software, try to do it under a native Windows system.

Just reporting back that I have tried the program under a 64-bit Windows 11 on an Intel box and it worked well.
Can I ask that either the sources be made available or a Linux/MacOS version be created. If the interface i sQt then that should be fairly straight forward.
Thanks for the support.