microSD error

I have read all the posts on subject but have the same problem as previous posts - using version 2.50 firmware now but original firmware also didnt work. I have tried two cards - both SanDisk 2GB, having not been able to find a smaller one. Get “File NoPlace” error. I have formatted the card through the USB connection to FAT16 with a command line from my Mac and can save and read files from the Mac, so the hardware seems to be working - have put dat files File001 to File005 on the card. I tried to create just a 500MB partition, but the Mac reports the card as 1.98GB.
I think when I first tried to use the card with the original (V1.5 ?) firmware, writing to the card from the NANO destroyed the formatting, requiring reformatting from the USB. However, with the newer firmware which doen’t seem to need rebooting with the -> key pressed, the formatting stays OK, but no files are saved from the NANO.
If I remove the SD card with the NANO switched on, and replace, I get a different error “Micro SD Err”. Rebooting gets back to the normal File NoPlace" error.
Can someone explain what is going on, and how I can determine if there is a real hardware fault on the NANO, please.

I have now managed to create two partitions on the microSD card from the USB inteface - the first is just under 1GB and formatted FAT16, but still cannot write waveforms/screen dump with the NANO.
Still needing to know if I have to find a 1GB card - others claim to have got 2GB cards to work.

Hello Tony!

I use Sandisk 2GB (no SDHC) without problem. I formated it FAT (16).

Do you copied the files FILExxx.DAT and CONFIG.DAT to the SD?



Hi Ricardo
Thanks for the advice - I hadn’t put config.dat on the card (as per Syberian post re firmware 1.5), and also I changed the filenames to lower case as also suggested.
However, it made no difference. I tried reloading Paul’s 1.5 firmware instead of the current 2.5, and again get the “File not Exist” message.
Since I have tried two different SanDisc 2GB not SDHC cards, I am beginning to think I have a hardware problem in the NANO, even though I know that the card works when the NANO is used as a USB card reader.
I would be very grateful if one of the chinese designers can come onto the topic and give us a little more insight.

Paul has just posted version 1.6 - supposedly for people with SD problems. I just tried it, but still get the “file not exist” error.

Aha - need to remove the SD card, then it writes to the ARM memory.

You need the filexxx.dat files to create placemarkers on the sd card to save data files and you need imagexxx.bmp files on the sd card to create placemarkers for the image files otherwise you get ‘no place’ errors. (xxx=001->255). This is because the firmware does not create files but simply replaces existing files.

I did this and ot bmp files on version 2.5 but I also found that when the usb cable is connected I couldn’t get the Nano to save any files at all.

If you aer having problems with sd card types try to format the card from windows over the USB cable as before i did that I kept geting sd card errors even though I had formatted in an external card reader.

Thanks pwdixon for the tips. I have again gone through all this - the card is formatted using the USB interface - fat16 in a size just less than the full 2GB - my Disk Util software reports 1.98GB. I have created both image and waveform dummy files 001 to 005. The software is Pauls latest 1.6.02p which writes to the ARM memory if the card is missing - I have successfully saved and restored a waveform this way. When the card is plugged in I get the “File Not Exist” message when trying to write a waveform. If I boot the NANO with the M key pressed to enable USB communication, then the file FI command is bypassed. The files on the card do not get corrupted by the NANO as seem to happen with earlier versions, and the dummy files are there when I read from my Mac.
I have not retried the version 2.5 software to experiment with bmp files again, but I have no doubt I have not yet fixed the fundamental problem.
Still looking for advice

I recieved my DSO Nano yesterday and updated to 2.5e firmware. Today I played with the SD Card until it worked. I ended up using FILE000.DAT, FILE001.DAT, … and IMAGE000.bmp, IMAGE001.bmp to get it working. I had to start with files from the rar. To get the image files, i had to use the converter for the first one and rename it.

To make it easier, here is a zip containing a folder with the files, put the files/images directly on the sd root directory. Hope this helps.

SDFILE.zip (180 KB)

The zip contains files 000 - 050 and images 000 - 050

If you get the “File NoPlace” error while saving either a File or a BMP this may help.
Recently I bought an Adata micro SD 2GB card to use with my DSO nano, unfortunately it didn’t work.
With version 2.31 and the latest version 2.5 I always got the “File NoPlace” error.
So I tried all of the suggestions in this forum but nothing helped.
I finally started debugging the first firmware version 1.0 and latest firmware version 2.5.
Luckily for me version 1.0 could save files to the SD card.

I found that the Root_Addr calculated the wrong address in version 2.5.
So I forced the Root_Addr to the correct address and I could save and load files and save
BMP files.

To have a nicer solution I took the small part of the version 1.0 code and integrated this
into the version 2.5. Just now I also got access to a SanDisk 1GB card and this worked also.

Another thing is that is also works with FAT16 and FAT32 formatted cards.
The FAT16 and FAT32 support was available since version 1.0 of the Software.

I attached the two source code files and the DFU files so you can download it immediately.
The files changed in the sources code are:

  • files.c (for correct calculation)
  • main.c (To remove the initial purple demo wave).

The source was compiled with version IAR5.5 but if you copy only these two files to the
IAR4.0 source it compiles also.

The third attachment is the contents of the SD card (which was posted before),
unzip it and copy the contents to the root directory of the SD card.

Because I can’t give any garantees I only hope it works for you to!
I couldn’t upload the complete source because it is to large.

Kind regards,
Files.zip (2.58 KB)
SDFILE.zip (165 KB)
DSO_nano_dfu_files.zip (25.7 KB)

Hi it seems that the max attachments is 3.
So here is the last attachment.

main.zip (4.61 KB)

Hi pjve64
Thanks for the new code and sources. I uploaded the 2 dfu files and fully populated the SD card with the bmp and dat files, but I’m afraid it has made no difference - I still get File NoPlace errors. Reading the files from the USB, as expected, they have not changed. What next?

Hi Tony,

As I only have access to two SD micro cards which both work with my changes. I can’t really tell why it doesn’t work for you.
As I understand from your post is that you get the File NoPlace errors for both BMP and DAT files?
Maybe a silly question but did the software download work? You can see this immediately when starting the DSO nano because the purple demo wave is not displayed anymore.

I found another small bug in loading already saved DAT files. The index counter FILE001.DAT FILE002.DAT (001 and 002) does not work so you will always see FILE001.DAT.
Although this has nothing do with your problem, maybe others who tried the fix discovered this aswell. I’m working on that now.

I may help if other people who downloaded the changes would tell about their experiences.

Hi pjve64

Yes, the software download worked OK - even though you left the same Application version number 2.50, I can definitely state that the purple demo is gone. I get File NoPlace errors when trying to save any bmp or dat files.
Further info:
I have tried 2 SanDisk 2GB cards.
If I try and load a dat file then I do not get an error - just nothing happens. I know the SD card and hardware connection to the processor works OK because I can fully read and write to the card from the USB interface. If I try to write dat or bmp files with the USB connected, I get a Micro SD Err message showing that the card is not available. Loading a dat file with the USB connected, nothing happens again.
Reading the NANO USB on my Macbook the card shows formatted MS-DOS (FAT16) capacity 1.98GB. 11.9MB has been used.
I named it WAVEFORMS when I formatted it.
Reading the NANO USB on my Macbook using Parallels and Windows XP shows Drive WAVEFORMS(E:) file system FAT, capacity 1.84GB used 11.2MB, hardware e-Design DSO Flash Disk USB device.
Not sure why the size reports are different, but dont suppose it is significant.

Lets hope we can get to the bottom of this


Hi Tony,

I’ve spend some time browsing through FAT16 information and found some interesting information.
The following is very important:
When formatting the SD card ensure it has only 1 partition (not 2 or more). Version 2.5 and earlier versions have very basic FAT support and expect 1 partition with the information stored in Partition table 1. This however is not always the case as I found out on different web sites. Even with 1 partition the information can be stored in Partition table 2 and if this is the case DSO can’t find the files.

In order to debug your problem I need some information which needs a free microsoft tool called secinspect. This tool can show the contents of the Master Boot Record and the contents of the Primary Partition and is run from the command prompt.

You can download it at the following address (it is also attached):
microsoft.com/downloads/en/d … laylang=en

I understand you are primarily running on a Mac, unfortunately this tool works only on Windows. Can you format the sd card on a Windows PC and run this program for me?

If so open a command window and execute: secinspect > microsd.txt (or another filename if you prefer). Post the information so I can download it.

Attached is an example of the output.

You can also try the new BenF firmware although I think it will not work (I’ve tried it and it wouldn’t read the card either).

With this information we can find out where the information is stored on your card and adapt the firmware.

Kind Regards,
microsd.zip (2.23 KB)
secinspect.zip (121 KB)

Hi pjve64

Thanks for your advice and software. Although it may not be needed now - BenF has just posted his rewritten V3 app and lib which also works with FAT32. I reformatted my card from windows as FAT32 and put his sample files on the card. Now I can actually read and write waveforms for the first time. If you think it is worth rewinding to gather more info, I will load the old firmware and reformat the card FAT16 - i think you are right - I did something with partitions to reduce the 2GB to less than 1GB in keeping with some early posts, so it may have been the location of the partition tables. But perhaps now BenF has rewritten the lib, we might not have to go into the details.
Let me know if you would like me to continue the investigation

Hi pjve64

I ran the sector inspector code on the newly formatted FAT32 SD card. The zipped file is attached - I believe the last record concerns the NANO SD card. Not sure whether this is any use now.

tonyssd.txt.zip (4.33 KB)

Hi Tony,

I had a quick look at your data and found that the newly formatted card has the correct table entries (no surprise because it worked).
So if your happy with the new BenF firmware we will leave the investigation as is.

Thanks for the cooperation.



I’m getting Mad with this MicroSD
When i try to save or load a file i get No file error

I’m currently running BenF application and Lib 3.01 and have a Sandisk MicroSD 2GB (non-SDHC)
I’ve tried to format (with a external reader) Fat16 and Fat32 (with winxpsp3) and i copied the BenF example file in it.
i also looked with the secinspect tool and i’ve only one partition in the microSD.

if i get the No file error, it should mean that my MicroSD is compatible with SPI Mode ? (i can also access it using the DSO nano as a reader …)

What can i try next… ?



Hi Nico,

Please post this in the BenF thread, because no one else is able to help you with the BenF firmware.