microSD error "File not exist" on Paul's firmware 1.5


I just bought a 2GB Kingston microSD card to use on my DSO nano. I formatted it on my computer using the command “mkdosfs -F 16 /dev/sdb1” and then created a blank file named “FILE001.DAT”. I am running Paul’s firmware version 1.5. When I try to save the waveform I get the error “File not exist”.

What am I doing wrong?

Thank you for your help :smiley:

MicroSD above 1G is not support well , you need buy another one .

Oh I wish I knew this beforehand. I literally just got this one in the mail today. :neutral_face:

I’m going to try and format it as a smaller size (below 1GB) and see if that helps.

I can use the microSD card fine as a USB-reader (holding down “M”)… what causes the error “File not exist”?

Try to copy those file to the root of your card,
brsbox.com/filebox/down/fc/e … 90f73668c9

Well, I copied all the files in your .rar to the root of the SD card (now partitioned to 128 MB) and I still get the same error message. Luck is not on my side it seems :frowning:

Sorry , that all I can help you.

It’s alright. I appreciate you trying. Maybe in the future a new firmware will better support SD cards.