Micopython 1.22.2 generic not working for xiao esp32c3

I am trying to get micropython running on the xiao esp32C3.
I have a important demo that I want show the RISC-V xiao ESP32C3 running python.

I download 1.22.2 generic following the instructions.
I flash it but I get
Build:Feb 7 2021
rst:0x7 (TG0WDT_SYS_RST),boot:0xc (SPI_FAST_FLASH_BOOT)
Saved PC:0x40047ed2
mode:DIO, clock div:1
Invalid image block, can’t boot.
ets_main.c 333

When I try to compile micropython it I get
CMake Error at /home/ubuntu/esp/esp-idf/tools/cmake/build.cmake:268 (message):
Failed to resolve component ‘esp_adc_cal’.
Call Stack (most recent call first):
/home/ubuntu/esp/esp-idf/tools/cmake/build.cmake:304 (__build_resolve_and_add_req)
/home/ubuntu/esp/esp-idf/tools/cmake/build.cmake:599 (__build_expand_requirements)
/home/ubuntu/esp/esp-idf/tools/cmake/project.cmake:605 (idf_build_process)
CMakeLists.txt:58 (project)

This is important for selling many esp32c3 for education.

I there,
I don’t think it has enough ram for micro python??
or was it in Boot Mode when you flashed it. That’s a boot loop Error you have.
You have a link your following.? or a wiki
GL :slight_smile: PJ

I down loaded the python that was suggested, 1.22.2

I first tried using thonny to flash it but got FFFFFFFF
I then tried esptool.py to load it .
Finally i tried to load it in boot mode, and then bricked it, I see no USB port now.

I held the boot down while poweron, now see usb port. I load python now.