Method Not Found When Parse Args

imgur [DOT] com/Enx77zA
(they won’t let me put an off site url…)

Hello! I love this little Wio Link board but I am having a hard time with it. I can’t get my buzzer to turn on. It currently uses a generic digital out but whenever I try to send data to it it gives me a strange error. Method not found when parse args. Am I doing something wrong?

You can add a picture within the forum. below the message box there is a gray box which says"upload attachement" use that.

Does the api work in the app? Just tap on api, scroll down to the one you want to test fill out the box with 1 and click post button.

Yes, Please post more info.
And the buzzer need PWM out. Refer to

If you use digital to generate PWM single with Generic Digital API through network. It can’t work, because the network delay can’t control.


Oh I didnt know that, I tried using the insert image up top, not upload attachment. Thanks for the notice.

Yes the API in the app works perfectly, and I was able to get the buzzer sound to go. I just can’t get it to work with curl. Whether I paste the exact link found in the API into a browser, or try to get the board to sound using curl like I found in your guide, it returns “Method Not Found When Parse Args.” I was able to use the guide to log in, get my user ID, list my boards, and all of that with curl however. Is this because it is a digital out?

I was actually using the mobile app API before trying the curl guide, and the buzzer was working with a boolean on/off. I don’t think this is the buzzer’s problem, but something having to do with curl. I posted a more detailed explanation just above this.

Can you post the CURL command on here?

curl -h “Authorization token: [MyBoard’sToken]” … value/10.5

I have a feeling it has something to do with the right side of that URL. I have tried things for it found in my phone api like “v1/node/GenericDOutD0/onoff/1” but that didn’t work either and gave me the same error. The “/node/Grove_Example1/float_value/10.5” is what I found in the online api, and decided to try it but again returned that error.

Why you have a Grove_Example1. It’s for test. Can you remove all Groves and add new Groves, Updated.
If still have issue. Please post you api url on here.

Have you tried a “POST” instead of a “GET” yet?

curl -k -X POST … ********** got it working, thanks for suggesting this. I didn’t realize that the mobile API gave the curl commands either.