Many troubles with RN171

Good morning, everybody!

So, recently, I bought couple of Arduino Leonardo and couple of Seeed Studio WiFly RN171-I/RM Boards. I downloaded library, installed it, like it was told here . And then, I tried to do examples, step-by-step. So here troubles begins:

  1. First of all I attended, that D5 LED blinking all the time, literally. Since I plugged micro usb into my Arduino it started blinking and never stop (Well, it stop blinking, but I will describe it later)

  2. I uploaded example code to access CMD mod and Arduino respond… nothing. Well, I thought, that it could be some trouble with CMD, so I decided to miss this one and try next example, to connect to my home WiFi, so, next problem:

  3. Shield can connect to my WiFi, but for, like 5 secs, and then It disconnects and trying to connect again. Iturned on DHCP on my router, like it said in example, but it didn’t help, then I tired do make it static IP ( via wyfly.staticIP(); ). And it didn’t work too. I made my phone as a WiFi point so I can fast check Shield’s IP – It never changes, despite I try to make it static or not. But by this point, D5 LED stop blinking, while connected to WiFi and, after disconnect it start blinking again. After this I decided to update my firmware (Later I decided, I cant do it without internet connection or without CMD, but before I realized it):

  4. When I’m trying to check my Firmware version, it shows me it is -1.0.

After making last point I was completely confused. I tried to ran CMD with couple of ways I found on the internet, but my shield never reply. Now I don’t know, if it is me doing something wrong, or I got bricked shield (I tried all this things on both of my boards). I found this page, but for now my brain so scammed I can’t understand a word from there, so I will check this one later. And now I will appreciate any advice. Because now I don’t know, If there is some way to fix my boards, or only solution to send it back to seller and try some other shields. Thank you!