Maixduino setting up arduino board manager

Myself and a colleague have been trying to load the Maixduino extension into the Arduino IDE (1.8.10 or 1.8.12) for Windows.
I have tried both of the suggested lines in Additional Boards Manager URL the file->preferences:
When we try to install the Maixduino package in Tools->Board Manager, it fails while trying to load it, so it does not appear in the list of boards.

We have tried multiple times with only one success, that we have not been able to repeat.
Is there something going on with the website holding the .json files? Has anyone else had these problems and found a solution? Thanks!

Just to confirm – same problem for me – must be server problem – think it was working last week.

We have a discussion on this going at:

One solution that works is use this URL in the File->Preferences block:

Good luck!

Hi dreschel,
Thanks for steering me to the BBS.
The temporary URL works fine for now.
That contribution of patmolloy appreciated.
Seems like the captcha is blocking access …
BTW - preferring MaixPy these days and try to get up speed on PlatformIO.

Hi Allen, I was just looking into MaixPy this morning and downloaded all of the files. I will definitely have to give that a spin as it looks like most of the object detection programs are using Python.
Have you seen this:

OK, tried MaxPy and seemed to have bricked my Maxduino. Could someone post the versions of the firmware and kflash that work. And any other hints that may get me running again.

Hi dreschel,

Here are some links:

The cn.dl.sipeed seems more “friendly” – for whatever reason(s) captchas and other limitations still seem to impede simple downloading!

BTW thank you very much for the youtube reference – hadn’t it seen before and need to review it more carefully.
Also am using microSD card – seems it can only be max of 4 GB so had to format a 16 GB card down to a single FAT 4 GB partition.


Thanks Alan. I am back up and running and got the MaixPy Face detection demo running (not real stable but it detects surprisingly fast). The instability may be due to my work computer’s multiple level of safeguards.