macOS (Catalina) isn't detecting Seeeduino V4.2


Can anyone help me out with Seeeduino V4.2 (
My MacBook Air (Catalina 10.15.3, which doesn’t support 32-bit application anymore) isn’t detecting serial port, neither showing up in About This Mac > System Report > Hardware > USB, and not even in Arduino IDE. But board LED light-up when it is connected with mac.

I tried every driver (FTDI, CH340, SiLabs) out there. Even tried with a different cable. Nothing seems to work.

Any clue what is wrong with it or what I’m doing wrong here?
(And don’t tell me to try this on a different computer. I want this to work on my MacBook only)
(Also, already installed Seedunio AVR 1.3.0 from boards manager)

Thank you.

Hello Anysh! I also met the same problem before. Now the software has been updated. Please download the latest version and try again to see if the port can show up.

Port detection has nothing to do with software (Arduino IDE) as the port is not getting detected on the USB bus itself. Tho, I updated the software, still facing the same problem. Also, check this post: