Macbook air not finding the serial port

Hi I purchased a new Wio terminal and my MacBook air couldn’t find the serial port. When I plugged in the old one (purchased a couple of months ago), it works fine.
Tried sliding down a couple of times, but nothing happens.
Are there any other tricks I can play? Thanks.

Hi Raymond_Wong:
This is a very common problem with wio Terminal. The serial port caused by the crash of wio terminal due to incorrect models and methods cannot be automatically identified. You can try to restart Wio and first dial the switch up (maybe you did not dial up, only the way to slide down is reset, so you failed). Slide the switch two more times to enter the boot mode as shown in the following figure. At this time, wio will be in the boot state, and the blue Led light on the back of the WIO will blink in the way of breathing. At this time, you can see that the port is recognized again:

If you can not succeed, you can contact me in time, I will see the first time to reply to you and help you solve; It would be great if you could solve the problem successfully

Thank you very much for your prompt reply. I tried yesterday but didn’t work. However, after reading your reply and I tried with more patience until I see the blue led light blinking, it is working now and I can find the port. Thank you.

I got the following errors when I tried to upload an old file.

Arduino: 1.8.19 (Mac OS X), Board: “Seeeduino Wio Terminal, Master, Enabled, 120 MHz (standard), Small (-Os) (standard), 50 MHz (standard), Arduino, Off, On”

/Applications/ -dump-prefs -logger=machine -hardware /Applications/ -hardware /Users/raymondwong/Library/Arduino15/packages -tools /Applications/ -tools /Applications/ -tools /Users/raymondwong/Library/Arduino15/packages -built-in-libraries /Applications/ -libraries /Users/raymondwong/Documents/Arduino/libraries -fqbn=Seeeduino:samd:seeed_wio_terminal:role=master,cache=on,speed=120,opt=small,maxqspi=50,usbstack=arduino,debug=off,txrxled=on -vid-pid=2886_002D -ide-version=10819 -build-path /var/folders/bq/j674zc6x7qx13kklx57pn6nc0000gn/T/arduino_build_886915 -warnings=none -build-cache /var/folders/bq/j674zc6x7qx13kklx57pn6nc0000gn/T/arduino_cache_641253 -prefs=build.warn_data_percentage=75 -verbose /Users/raymondwong/Documents/Arduino/Lakshantha/c1.3_text/c1.3_text.ino
/Applications/ -compile -logger=machine -hardware /Applications/ -hardware /Users/raymondwong/Library/Arduino15/packages -tools /

Uploading using selected port: /dev/cu.usbmodem1101
/Users/raymondwong/Library/Arduino15/packages/Seeeduino/tools/bossac/1.8.0-48-gb176eee/bossac -i -d --port=cu.usbmodem1101 -U -i --offset=0x4000 -w -v /var/folders/bq/j674zc6x7qx13kklx57pn6nc0000gn/T/arduino_build_886915/c1.3_text.ino.bin -R Cannot run program “/Users/raymondwong/Library/Arduino15/packages/Seeeduino/tools/bossac/1.8.0-48-gb176eee/bossac”: error=13, Permission denied
at java.lang.ProcessBuilder.start(
at java.lang.Runtime.exec(
at java.lang.Runtime.exec(
at cc.arduino.packages.Uploader.executeUploadCommand(
at cc.arduino.packages.uploaders.SerialUploader.runCommand(
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
at cc.arduino.UploaderUtils.upload(
Caused by: error=13, Permission denied
at java.lang.UNIXProcess.forkAndExec(Native Method)
at java.lang.UNIXProcess.(
at java.lang.ProcessImpl.start(
at java.lang.ProcessBuilder.start(
… 11 more
An error occurred while uploading the sketch

maybe there can help u

Tried to upload the Blink example, got similar error message.

Probably because I’m not a MacOS host, I’m using a windows host, and on my computer I managed to get the program uploaded.
In addition, I have sent my wio upload video to your email
I will discuss and solve your problem with our colleagues as soon as possible. Please wait patiently


We have done tests on MacOS computers and encountered related problems. The solutions are as follows:
1.Reinstall the wio firmware. The upload may fail due to the wio firmware version
The firmware version reinstallation method I have written in the wiki:
Wio Terminal Retro Gaming Firmware | Seeed Studio Wiki

2.MacOS requires licensing of usb
In your error message we can clearly see a few words “lack of permission”, the specific method you can search through Google, the USB consent authorization can be burned

I reinstalled the Arduino software, and it seems like the problem is solved. Thank you.