M1 hotspot: ethernet and wifi both talking, causing 'relayed' status?

I have a SenseCAP M1 helium hotspot and I initially configured it for wifi but have since given it an ethernet connection. I notice now that my router tells me that the device is talking on both interfaces at the same time.

Normally, I guess I wouldn’t care but of course, I don’t want to be relayed and since I can only forward port 44158 to a single internal IP address, I suspect my hotspot is relayed about half of the time, no? (Helium Explorer says it’s not relayed but SenseCAP dashboard says it is. The dashboard itself claims to be more accurate than Helium app so maybe I really am relayed much or all of the time?)

How to manage this? Can I unconfigure or disable wifi remotely somehow? I don’t see a way in the SenseCAP dashboard unless maybe through the terminal CLI?

A better solution would be to have it use ethernet when available then fall back to wifi if needed. RFE?

Firmware version: 2021.10.18.0

Any guidance is appreciated!

2 Likes

So I physically accessed my M1 and connected via Bluetooth, told it to forget my configured wifi network and now it’s only talking on the ethernet interface per my router - good. Earnings are up a bit but I’ll need to monitor for a few more days.

The Sensecap dashboard however still shows relayed = yes while Helium Explorer still shows not relayed. The config is straight forward now (with wifi disconnected) so I think that Sensecap dashboard is incorrect. Sensecap dashboard is also not showing my correct public IP address so that may be the reason and a potential bug to be addressed.

I have the exact same issue! Any updates since then? Thanks for the update on disabling the Wifi option through pairing. Going to try that now! I also believe there is a bug in the programming not being able to choose one or the other internet connection with both connected. As you correctly observed, You can only choose one IP address in your router to port forward within this scenerio.

I was having the same issue. I attempted to create a static IP with the Ethernet and WiFi MAC’s separately for the same device ip address. Unfortunately you can only do one or the other. I was able to disconnect the Wi-fi through the Helium App, but now I’m having other issues. Using SenseCap Caps consule I see my Hotspot Online Status as Off, but my Helium Online status as On. I’m also not seeing any P2P connections now. I think I may have a bad Cat5e??? Will try to trouble shoot more today.