LTE Initialisation Fail

I have purchased a Wio LTE AU Version from Seeed and I am using the ‘Play with Socket TCP/UDP client’ code provided on Seeed Wiki which I have had work for me before. But now it is failing to initialise the LTE. I am not sure if this is a hardware issue, but initialisation should be seperate from antennas etc. I tested running the LTE init function bit by bit and it was the CREG AT command that it fails on… eg. Fails to get the registration status. I was wondering wherther tou would be able to help. I have included screenchots of the working code and what it is now doing.


Which version of the Wio LTE do you have? Can you check with the SIM Module and the antenna whether it’s connected properly? please let us know.

Hi, I have the Wio LTE AU Version v1.3- 4G, Cat.1, GNSS, Espruino Compatible Module and the SIM and Antenna are correctly connected. Thanks

Hi ,

which sim are you using? Is it 2G/3G/4G sim?

I am using a 4G SIM and I was able to use data on my phone when I used the SIM and configured the APN, which makes me think the issue may not be with the SIM?

HI, ’

I was thinking about different bands of LTE.


can you try with 2G/3G sim?

If it was working intially with this SIM is it likely to be an issue with the SIM? (2G and largely 3G are phased out here)

Ok, Is it worked before? then it might be not an issue with the sim.

I just tried a 3G SIM and I get the same behaviour for 4G SIM and also no SIM -> it is just repeating ‘initialising LTE…’ over and over

Thanks for the replay, can you share code that you using?

I am using the following code base:

and specifically the TCPConnect example in the examples folder