Lora SX1278 connection to Seeeduino Xiao fails to start?

I’ve been trying to connect my SX1278 to my Seeeduino Xiao as it already works with my Arduino Nano for this tutorial: https://how2electronics.com/interfacing-sx1278-lora-module-with-arduino/

However connecting all the cables correctly still results in “Starting LoRa failed!” and I think it’s because the XIAO lacks a CS pin. I’ve tried manually assigning the pin to pin 1 and 4 but neither have worked. Am I missing something obvious here?

Edit: I’ve since used

#define ss 4
#define rst 1
#define dio0 2

and LoRa.setPins(ss, rst, dio0);

This allowed me to get it working exactly once, now it won’t work again giving the failed message. Very confusing.

Hi did you try to connect a second DIO pin as far as i know the most LoRa libraries need 2 DIO pins.
I use the XIAO with an RFM95 SX1276 i use pins
SS => 1
dio0 => 2
dio1 => 3
RST not connected
I use the GitHub - mcci-catena/arduino-lmic: LoraWAN-MAC-in-C library, adapted to run under the Arduino environment library