LoRa E5 Mini Not Powering On


I am trying to use the LoRa E5 mini development board, and it is working with the AT firmware through serial terminal on my laptop when connected through the USB-C port and so I know the board is working.

However, I would like to use this board with a Raspberry Pi and so I am trying to power it through the power input terminals on the board. There is no current draw from the board when power on in this way and it will not communicate over the UART pins. I have also tried using a bench top power supply in fear that the raspberry pi was not supplying sufficient current however this was also unsuccessful.

I am wondering if anyone else had such problems powering on this board or if they know of any suggestions on how to solve this issue?

I really appreciate any help people can offer.

May you please detail how you power the Lora E5 dev board ? through the battery connector ?

I powered the board through the power input +/- terminals shown in the figure below labeled Power Input (3.7-5V).


I have tried this with header pins and jumper cables and have also tested it by soldering the board.

Sounds ok this way :wink: Did u check if your power supply is working once connected at E5 ? check voltage on the 2 pins on the board while powered ?
According at board layout you should be able also to get some voltage on TP1 on the board when it’s powered :wink: (https://files.seeedstudio.com/products/113990939/LoRa-E5%20mini%20v1.0.pdf)

Testing it again in the lab today it is now drawing current but it is fluctuating greatly between 0.04 A and 1.5 A. This is without the pi connected to a HDMI cable and so I am thinking with the HDMI cable attached to the pi this much current is not available hence why I was getting no current draw previously.

There is 3.3 V across the RX and TX pins but they are still not connecting or communicating over UART. There is no indication from the RX and TX LEDs when connected in this manner.

Ideally I want to be able to use the LoRaRF python library, which I have linked below, as this is a better end solution versus the AT commands, however this fails to connect each time and so I am hoping solving this issue with the UART connections will help see a reason for this library not working also.
(LoRaRF · PyPI )

To update this, I have now been successfully able to connect to the Lora e5 mini through the header pins of the raspberry pi with successful communication over UART.

I am still unsuccessful using the LoRaRF library. This is using SPI interface for communication, would this require different firmware on the LoRa e5 or should the factory firmware work fine with this ?

Well you are supposed to delete the AT firmware in it to be able to use your own firmware so might be the reason it’s not working ! Be careful that if you delete the AT firmware you won’t be able to reinstall it after !! Wio-E5 mini - Seeed Wiki

This Python library I am looking to use is on the Raspberry Pi side, would you be able to point me in the direction as to what firmware I programme onto the LoRa E5 mini so that it is compatible ? Or another library which I can use on the Pi side which may be better linked to work with the LoRa E5 mini ?

From what I understand the Python library you wanted to use is to control through SPI and GPIO of a Raspberry a Lora chipset. In E5 Module the Lora chipset is integrated with a microprocessor that you program straight (you don’t need anything else out of it !). Did you get a look at Seeed documentation about it ? You’ll have to install the ST IDE to program it properly and everything will run in E5 without need of a raspberry :wink: Wio-E5 STM32WLE5JC Module - Seeed Wiki

Just so that I understand you right, the E5 chip integrated into the MCU on the E5 board can not be communicated with through the GPIO pins of the LoRa E5 mini ?

If we were to use the GPIO pins of the raspberry pi it will require the need for a different LoRa chip which is not integrated into a microprocessor?

Yeah I have taken a look at the Seeed documentation and I will give it a try to program directly onto the E5 with the use of the examples on the Speed Wiki page.

Thank you for your help on this @vincen