Lora-E5 Dev Board - Battery power

I flashed an WIO-E5 dev board with the LoRaWAN_End_Node example code using STM32CubeIDE and an external STLINK v3 programmer. The board is powered via USB port by a PC, which also acts as a UART to communicate with Tera Term capturing program output. The board runs the code runs as expected, joining to Things Network, sending temp and VDDA data, the Tx LED flashes on each Tx, output to Terra Term is fine, I can debug the code, all good.

My question is how do I run the board without the USB connection to the PC? I have tried booting the board with the included battery pack attached to the JST connector, and with a USB charger attached to the USB port, but neither method works. The Tx LED does not activate and there is no activity on TTN.

I have looked online for solutions, but there is absolutely nothing I could find on using the board untethered.

I have an STM32WL Nucleo-64 board (MB1389), which has an WL55 instead of a WLE5. It works fine untethered from the PC with the same end node example.

Can anyone help me out?

Hi there,
Is there any !(WhileSerial) in the code?
May be waiting for a usb to be plugged in? Debug on/Off
my .02
GL :slight_smile: PJ

Good point.
This is example code utilizing STM sequencer.
I commented out the calls to LoRa in main()
I put an LED blinker and some UART output to USB with delay in main() infinite loop
Works as expected connected to PC via USB. LED blinks and text on terminal.
Disconnected USB, attached battery - Nothing. No blinking.

Hi there,
Can you post up the code? I can look and see?
GL :slight_smile: PJ

I am using the code from this project.

It is based on the STM LoRaWAN_End_Node example.

Thanks for your offer of help. At this juncture, I don’t need any more help.