Longan Serial CAN Module : Not responding to AT Commands

Hi all,

We use the Longan Serial Can module as interface with an android phone to access to a can bus.
To fit with the CAN Settings we have to reconfigure modules at 250KB/s and accept extended identifiers.

To do this we use this sequence :
+++
AT+C=15\n
AT+M=[0][1][00000000]\n
AT+F=[0][1][00000000]\n
AT+Q\n

Our problem is : we have to send several time each command to have an OK response. Many time, the module response is “ERROR CMD” and return the command with corrupted bytes
+++
ENTER INTO SETTING MODE
AT+C=15
OK
AT+M=[0][1][00000000]
AT+M=[0][1][00000000]
ERROR CMD
AT¥ªÚÁ][1W+‚‚‚‚‚‚0]

This behaviour was observed on several modules.

We use an FTDI 5V as serial to USB interface.

Someone has encoutered this problem, how it can be solved ?

Thanks for your help

Hello,

Did you mean that you use an FTDI 5V cable to connect the Longan Serial CAN module to an Android phone and then send AT commands to the module from the phone? Do you have a CAN device connected to the Longan Serial CAN module?

I suggest you connect the module to a development board (using Arduino:SERIAL CAN BUS MODULE - Longan Docs) and try to set up the parameters correctly according to the provided tutorial.

Hi

We have already tried this with an Arduino board, sometimes the module does not understand the command. I saw that the module sent back what it received on the UART bus for an unknown command. So it looks like it is receiving or storing incorrect bytes, but we saw on the UART bus correct bytes with the oscilloscope.

It appears that the module cannot be configured with a baud rate set to 115200. At 9600 bps there are fewer errors and commands are received and executed more often.

In DATA mode, the module can operate with a baud rate of 115,200 bps without any problems.

So a bad solution is to configure the module at 9600 bps to send the bit rate, masks and CAN filter settings, then change it to 115200 bps.

Not all v1.4 modules support 115200bps communication… some do, some don’t… In SETTINGS or DATA mode, serial communication is not stable and the module does not respond to commands or does not send a message on the CAN bus.

I’m surprised because some modules bought at the same time, work as expected and others have errors.

Any tips or trick, to unlock the problem ?

Maybe you can reach out to Logan directly since it’s their hardware design after all.
https://docs.longan-labs.cc/1030001/#faq

Thanks i forward my problem to their support