Jetson Orin Nano on A603: No devices showing up when connecting host to USB type B port


I’m trying to figure out how to communicate between a host computer and my Jetson via USB. I understand that the USB type B port on the A603 carrier is supposed to function as a “device mode” port.

From what I can tell, the necessary services are running under Linux. There are two systemd services, which are both running, and there’s a whole bunch of nodes under “/sys/kernel/config/usb_gadget/l4t”. There’s also a rndis0 ethernet device, which is supposed to correspond to a gadget on this port.

However, when I connect a host to this port, listing the USB devices shows no new devices showing up. I’ve tried both a MacBook Pro and an Android phone.

I’ve also tried two A603’s, and neither of them seems to be presenting any gadgets through this port.

Is there something special I have to do to enable this port?


P.S. I’m asking here since I’m not getting very far on the Nvidia forums (How to use A603's USB-B port in device mode? - #4 by theosib - Jetson Orin Nano - NVIDIA Developer Forums).

Hello, you can refer to this Wiki to flash JP for A603.

As a matter of fact, if you want to flash JP, you need to put your own device into Forced Recovery Mode first. You need to connect a jumper wire between pin3 and pin4 of the 14-pin header to enter forced recovery mode.

This will give you output from your lsusb

I’m a little confused. Are you saying that to use the USB type B port in DEVICE mode, I have to put it in RECOVERY mode? I would have expected those to be two different things. I don’t need to do any recovery. I want an external host to see the Jetson as a USB slave device.

I apologize for the confusion caused by my previous response. I misunderstood your question. I thought you were referring to using the micro-USB port for JP flashing (Is the USB type B you mentioned referring to micro-USB?). In fact, if you want to use the micro-USB port, it can only be used in the forced recovery mode and solely for JP flashing purposes.

According to the spec sheet (, port W6 is a “1x USB 2.0 Micro-AB”, which the text refers to as “one USB 2.0 Micro-AB for versatile connectivity options.”

This is the port that I’m using, and I don’t see any other micro USB connector on the board. When you say “solely for JP flashing purposes,” this doesn’t sound very versatile.

Can you please clarify? Is this spec sheet in error about what it says?

The complete sentence is above. Its intention was to express that A603 has multiple interfaces available to choose from, rather than indicating that USB 2.0 Micro-AB has multiple connectivity features. I apologize for the confusion caused by that sentence.