Issues with Xiao BLE Sense not beeing seen after blink sketch and not reading sensor values

Hi Community!

I just received 2 Xiao BLE Senses and wanted to try them (I have a bit of experience with some other boards), but I keep having some issues:

  1. After loading the blink sketch, both boards wont be recognized as a port, nut the definitely connected to my computer. I only get rid of this issue by pressing the reset button twice.
  2. I followed the common instrucition and installed the seeduino nRF52 Boards and loades the correct library before. But when I try to run the “high levvel examle”, Temperature Valued are “inf” and the whole accelometer & Gyrosope Sensors dont work properly, e.g. Gyroscope permanently shows values around 2000 in x, y and z.

Does anyone know how I can properly read the IMU? I purchased the xiao BLE Sense, beause I just need theses Gyroscope values and send the via bluetoth, but I dont even get propper gyrosensor-values…

I would be thankfull for tipps!


btw also the pedometer example doesnt work. I’m often reading the boards-download must be “mbed-enabled nrf52 Boards” but I cant find a board saying “mbed-enabled”? I have “Seeed nRF52 Boards” 1.0.0

You are using an old on-board package, please re-update the XIAO BLE on-board package according to the Wiki.

oh thank you! the link disapperaed while I updated my Arduino IDE…

I did as you said and now I have the version Seeed nrf52 2.7.2, but when I choose Seeed Xiao nRF52840 Sense, I get the same errors with reading the values.

If I choose Seeed Xiao nRF52840 Sense BLE mbed-enabled (which is recomended for using the IMU), I get the error message:

Property ‘upload.tool.’ is undefined

And can’t finaly upload the sketch.

Its also strange, that in every guide the path to example is File > Examples > Accelerometer And Gyroscope LSM6DS3 > HighLevelExample

But for me it is File > Examples > Seeed Arduino LSM6D3S > HighLevelExample

That appears strange to me.

Or should I install Version 2.6.1 from the board manager?

Ok I found that this is a common problem that isnt solved yet? I use my old Arduino IDE and it works… Feels strange but ok.

Now I run into another issue (should I open a new thread for that?):

Could it be, that the functions

myIMU.readFloatAccelX(), 4


myIMU.readFloatGyroX(), 4

(the same for y and z)

are swapped? so the command of reading Gyro reads Acceleration levels and vise versa?

Because I get very odd images on my serial plotter. With gyro data, the the value of each axis should rest near one value, if the Sensor is in rest. But the gyro data show a short peak and than move back to near zero.

But withe the acceleration data, the values stay neraly stable, depending on the position of the device. But their range is weird between ±3…

Maybe I just think wrong but in my opinion these values are swapped.

Your problem will occur with Arduino 2.0, the R&D department is already working on this issue, please use Arduino version 1.x first.

I haven’t noticed this problem, I’ll test it out. Until then, you can also search for the relationship between the two.

Sorry, I was wrong here. The values arent swapped, I just needed to calculate the real positions from the raw values. I managed to do this, but are there any libraries that communicate with the Gyro/accelerometer Sensor?