Issues with DSO Quad... not triggering

Hi - I am a new user to the DSO Quad. I updated to the latest firmware and then started playing. When looking at fast signals, the device seems to trigger OK and generally work. But when trying to capture slow signals (ie 200ms/div) it just refuses to capture.

No offense meant to those that worked on the device, but the UI could use some significant work.

So, my questions:

  1. Are my triggering problems normal? Any suggestions?
  2. Are there better firmware versions that I should look into?


A lot of users are much happier with the community edition of the software. See on this forum for details.

For triggering at slow timebases I have most success using the manual trigger level controls. Also the community edition allows setting for a smaller capture window (just over a screen). For slow time bases the long capture window holds a lot of data (e.g. 30 seconds) so it can seem unresponsive.

Hi - you may be right that it was just filling its buffer and was thus not being unresponsive. I’m still not used to reading the status on this little device.

I’ve mostly figured out how to use it, but one thing remains that I cannot figure out: How do I move the trigger position? Not the trigger vertical position, but the trigger horizontal position.

Also, do I understand right that you can have multiple different versions of firmware installed on this device? If so, are there any guides to installing the community firmware in addition to the stock firmware?

It’s a long time since I use the stock firmware but on the community edition there is an XPos control which moves the display horizontally.

There are 4 program slots available for use by application firmware. Normally the a main scope application takes up 2 of these (the first 2). Other applications are compiled to go into different slots and you access these by holding down one of the main buttons when starting up.

Although it would be possible to have both stock and an alternate main scope installed (e.g. stock in 1+2, alternate in 3+4) most of the main scope applications are compiled for 1+2.

Loading new firmware is really quick and easy so it is very simple to try an alternate scope program and then revert back, but having tried say the community edition you won’t switch back anyway.

If you turn on the device with the left (run) button held down then the device enters load mode and when you connect to a PC it shows a simple disk drive. Most of the time you just copy a hex dump of the new firmware into the drive and it uses that to write the new firmware into the slot(s) addressed by the hex. For updating binary data like the FPGA code then you need to put in an .adr file first followed by the binary. There are lots of guides available see for example