issues uploading sketches to Seeeduino_ADK_Main_Board

I have issues uploading sketches to Seeeduino_ADK_Main_Board. It displays this message multiple times “avrdude: stk500_2_ReceiveMessage(): timeout”, and then says the serial port has been used by other programs .
I really want to get my thing o matic up and running but this extremely frustrating…

any idea?

Dear customer,

Please check on your PC is there any other program using the serial port?
Reboot the Arduino IDE that would be work.
Or you can set the serial port to another one.
It is choose the right board?
Any serial tools using with it? Please shut down.
Change the USB port, and make sure the USB cable is it OK?

Hope can help you.

Best regards,

I have been using the arduino for a while, I know how to avoid the issues you mentioned about, like Port, USB, blabla…
In fact, this issue is more problematic than you think, on the arduino forum there are many posts about issue of uploading programs to mega 2560, none of them really solves my problem. such as … #msg493290

So I do really need some more serious technique support from you, I guess there are something wrong on the bootloader or something similar, can you check this again,


I have tested with IDE 022,023, none of them works, no matter in Windows vista or windows 7. I always get the problem on , " fails to upload with:
avrdude: stk500_2_ReceiveMessage(): timeout"

I brought the board late last year, and tested it and nothing worked out, my previous post was here : viewtopic.php?f=4&t=2776

in your post, your solution doesn’t work. It seems it is easy to upload the program for you, I doubt is there a problem with the board itself?

I have a board mega 2056, uploading the program is perfect. I don’t what happens with your board,

USB driver ? my USB driver is working good with my android phone


reset, I used the reset on the ADK board before uploading, still doesn’t work.

This board ruined me a whole day, so frustrated doing nothing :frowning:

Dear customer,

Last question.
Could you try to use another PC to install the Arduino IDE and upload some code to Seeed ADK?
If still not success, it could be a dead board.
So after that you can contact to our QC via email, we would help you to fix it.

Best regards,


I have tried three different computer with windows vista, xp, windows 7, also with different versions of arduino, nothing works…
Can you tell me how to contact the QC for more detail?

best regards

Dear customer,

Go to tell our QC what happen with your board.


I have sent 2 emails still with no reply :<