Issues programming Seeeduino v2.21

My seeeduino v2.21 will not take sketches from my laptop running Fedora 15. I have the switches set to 5V and auto and am using Arduino 0022 with Board set to “Duemilanova or Nano w/ ATMega328” and the port is “/dev/ttyUSB0”.

Using another computer I was able to program the seeeduino. I was also able to program a friends Uno by just changing the board and port and it worked flawlessly so I am pretty sure Arduino IDE is setup just fine.

When I try to program: L, Rx and Tx blink and then I get:

Binary sketch size: 6078 bytes (of a 30720 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00
And then Rx and L blink about every second.

Any suggestions? I have tried connecting external power incase my USB ports weren’t supplying enough.

Is the reset switch in the auto position?

So it was set to “auto”. I have tried setting it to manual but it didn’t work any better.

Similar problem here. I am running Windows XP with Arduino IDE 0022 and have the board connected as COM11 with latest drivers (2.0.8) and “Arduino Duemilanove or Nano w/ ATmega328” selected as the board.

The reset switch is set to auto and I tried setting the other switch to both 3.3V and 5V.

When I try to flash, the Rx LED blinks every now and then, but no success.

This is the output I get when I try to upload the Blink example from Arduino IDE 0022 holding shift:

[code]Binary sketch size: 1018 bytes (of a 30720 byte maximum)
C:\arduino\hardware/tools/avr/bin/avrdude -CC:\arduino\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\.\COM11 -b57600 -D -Uflash:w:C:\DOCUME~1\ROBERT~1\LOCALS~1\Temp\build4667765253164332697.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
Copyright © 2000-2005 Brian Dean,

     System wide configuration file is "C:\arduino\hardware/tools/avr/etc/avrdude.conf"

     Using Port            : \\.\COM11
     Using Programmer      : stk500v1
     Overriding Baud Rate  : 57600

avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you. [/code]

Has anyone managed to solve this as I have the same problem and would hope that it is a simple fix???