IoT Button for AWS - No WLAN Setup possible, how to reset?

One of my new Seeed IoT Buttons for AWS does not react when I press the button for 7 seconds (or more) to configure its WiFi.

I tried different Panasonic batteries (NCR18650B) and also the USB-C cable alone.

Power Charge is not the problem, it works fine the same way with the other buttons.

Is there a way to “RESET” the button to factory defaults? Maybe something went wrong on circuiting the battery.

a) Is there a known issue why WiFi WLAN can not be configured anymore, even if power supply via battery and/or USB-C is provided correctly? (green light flashes, battery is fully charged)

b) Is there a way to reset or get back to WLAN setup when the blue light does not come up any more no matter how long i press the button in either mode (battery or USB-C) ?

Could not find any answers yet in this forum or via Google.

Thank you very much in advance and greetings from Germany,

Hi @frontimax
Sorry to hear about that.
I have sent an email to you to let you help us return it back.
We need to analyze the reason.
Thank you.

Actually my issue is when I try to configure Wi-Fi I get Configuration Failed - Please retry. Not sure what to look at. Tried several times

Hi @Jollymon
Please make sure update to the latest firmware following this .

How do you update to the latest firmware if you can’t get it on the wifi?

had issues with setting up wifi, failed 5 times. Then pulling out the battery and plugging in with USB C while doing the steps solved it for me. Hopefully it works for you too

Did not work for me. Same problem - does not configure wifi… :frowning: