IoT Button - Claim and Config Issue

I have a new Seeed IoT button, and I am using AWS 1 Click app to claim and config (running on iOS). I can scan the code, it prompts me to hold the button for 6 seconds and the blue light flashes. It then prompts for the WLAN config, I provide it and click Confirm, the confirm button in the app flashes but seems like it never pushed the config to the button. It eventually times out and the light stops flashing on the button.

If I say “No” to the WLAN config and just try to claim the button it asks me to press the button once, and the light flashed white, but the app says it is still waiting for the button press.

I have tried:

  • different WLAN networks, different manufacturers.
  • WLAN is WPA2-PSK
  • 2.4 is enabled along with low data rates.
  • Removed the iOS app and reinstalled.
  • Removed battery for hours and reinserted.

I am not sure this is a wifi issue as it acts like i tis not pushing the config, and the claim function along does not work.

Thoughts?

I also tried claiming the device via the AWS console, it prompts me to press the button once but it never completes the claim and the white light stops flashing on the button.