Installing hat 2 drivers on nvidia jetson

Hi. Im installing the ReSpeaker 2-Mics Pi HAT on an Nvidia Jetson Nano running Ubuntu. I’m following the instructions of the Jetson driver install page. Ive downloaded the repo several times, but stuff seems to be missing. Notably, one terminal command looks for a ko that is not in the directory. I’m not sure where the file is supposed to be if it is not included in the download. Here is the terminal command and result I am discussing (some characters do not show in this post):

~/seeed-linux-dtoverlays $ sudo -E KBUILD=/usr/src/linux-headers-4.9.201-tegra-ubuntu18.04_aarch64/kernel-4.9 make install_jetsonnano
cp: cannot stat ‘2xMCP2518FD-spi0.dtbo’: No such file or directory
install /boot/2xMCP2518FD-spi0.dtbo
cp: cannot stat ‘jetson-sdmmc-overlay.dtbo’: No such file or directory
install /boot/jetson-sdmmc-overlay.dtbo
cp: cannot stat ‘jetson-seeed-2mic-voicecard.dtbo’: No such file or directory
install /boot/jetson-seeed-2mic-voicecard.dtbo
cp: cannot stat ‘tegra194-p3668-all-p3509-0000-gpios.dtbo’: No such file or directory
install /boot/tegra194-p3668-all-p3509-0000-gpios.dtbo
Kernel module is installed, proceed to the next step
mkdir -p /lib/modules/4.9.337-tegra/extra/seeed || true
cp: cannot stat '/home/boatwhisperer/seeed-linux-dtoverlays/modules/CAN-HAT/
.ko’: No such file or directory
Makefile:164: recipe for target ‘install_jetsonnano’ failed
make: *** [install_jetsonnano] Error 1

Getting started with Nvidia Jetson | Seeed Studio Wiki
Hi, did you follow the tutorials in the wiki? Which step did you run into problems? Is your ubuntu running as a linux host rather than a virtual machine?
What is the version number?

Can you give us more information? This helps me troubleshoot problems! thx

Hi. Yes. thanks. Im following along closely with that page.

However, I’ve encountered several issues during the installation process, and the instructions seem to expect a Raspberry Pi-like environment, which is causing errors on my Jetson Nano.

Here are the steps I have followed and the corresponding errors I received:

I cloned the Seeed GitHub repository as per the instructions.
Ran the provided script, which resulted in errors related to missing /boot directory and dtoverlay command.
I tried to run the make all_jetsonnano command as instructed but received an error stating “No targets specified and no makefile found.”
Additionally, I tried specifying the correct KBUILD path to my kernel headers with the command:

Copy code
KBUILD=/usr/src/linux-headers-4.9.337-tegra-ubuntu18.04_aarch64 make all_jetsonnano
But I received the same error.

The kernel headers are located at /usr/src/linux-headers-4.9.337-tegra-ubuntu18.04_aarch64 on my system.

I am unsure how to proceed and would appreciate any guidance or alternative instructions to successfully install the drivers for the ReSpeaker 2-Mics Pi HAT on my Jetson Nano.

Has anyone else encountered these issues, and are there updated instructions or a different method I should be following to get the ReSpeaker 2-Mics Pi HAT working on Jetson Nano?

Thank you in advance for any assistance you can provide.

Im running Ubuntu 18.04 LTS. Not in a virtual machine.

Since my last post, I’ve been tirelessly working to troubleshoot the setup of the ReSpeaker 2-Mics Pi HAT on my Jetson Nano. With the help of extensive troubleshooting and guidance, I’ve uncovered several inconsistencies and roadblocks that I hope can be addressed or clarified:

Missing Target in Makefile:

The documentation mentions running the command make all_jetsonnano, but there is no target named all_jetsonnano in the Makefile located in ~/seeed-linux-dtoverlays/overlays/jetsonnano.
Incorrect or Missing Paths:

The Makefile references a destination directory /boot, which doesn’t exist on the Jetson Nano. Is there a different path that should be used?
Kernel Build Directory:

I updated the KBUILD variable to point to the correct kernel build directory, but this didn’t resolve the issue.
General Build Targets:

Attempting generic build targets like make all and make install also didn’t yield the desired results.
Search for all_jetsonnano:

A search for all_jetsonnano only yielded results in readme files, with no corresponding entries in any script or Makefile.
Alternative Instructions:

I have also scoured alternative documentation and community-contributed guides but to no avail.
I’ve documented every step of my process, and I’m more than willing to provide any additional information or carry out further troubleshooting steps if it can help resolve this issue. The goal is to have the ReSpeaker 2-Mics Pi HAT recognized and functioning correctly on my Jetson Nano.

I appreciate any insights, corrections, or guidance that can be provided. The ReSpeaker 2-Mics Pi HAT is a crucial component of my project, and I’m eager to resolve this setup issue.

Thank you for your time and assistance.