init rainbowduino

Hi dudes, need some help with my first Rainbowduino project.
For some reason my Rainbowduino V3.0 does not compile the cube sketches. Message ‘RB not declared’
Am i missing something?
When i do the blink sketch, it does compile and upload (fast blinking leds) without error notifications but no slow blinking led on output 13
I work with WIN 7 OS
As board i select in the Arduino programmer the Arduino PRo or Pro mini 5V. 16 Mhz
The serial port works fine.

Hi dear,

It could be your solder point week.
So check again is there any voltage when it is running?
And LEDs find?
Better attach your photo here let more guys help you.

Best regards,


Dear Yuri,
i bought the pre-assembled driver board, it looks very professional, and it has a sticker ‘QC passed’ Power is ok. (powerled on)
The simple ‘blink’ sketch does upload since in that case leds blink fast during upload.
The problem is that the CUBE sketches do not compile.
I use the sketches named CUBE from the Rainbowduino library. When i try to compile/upload with the ARDUINO programmer i consequently get the message RB not declared.
There are some more files of which i don’t know what to use them for, they have extensions such as .cpp (from C++ language) and .h When i paste these files in the Arduino programmer i even get more errors.
I’m a bit lost.
Does someone knows what’s missing here??.. please!

Hi there,

Can you run with our Rainbowduino demo code?
First you need to make sure the hardware is OK, and then post your code here or photo to let us know may be you plug the wrong side.
Arduino IDE what is the version?
And choose the right board to upload.

Best regards,


please understand what i try to say: i did not write or change any code, all i’m trying is to get the code from the Rainbowduino library compiled.
In the available code examples there is nothing called ‘demo’, so i tried the first ones called ‘Cube’ Please read my previous messages about the board type choosen etc.
The Arduino programmer is version 1.0

OK, Arduino 1.0 is not compatible with our libraries.
So please use Arduino 0023 IDE.

Anyway we are program for Arduino 1.0 IDE now, latter you can see we would attach on WIKI.

Dear Yuri,
i installed Arduino 0023 and i get the same error message during compile: ‘RB not declared’
Is there anything else i need to do before loading sketch CUBE1?