I downloaded the latest Seeeduino XAIO IDE files and I am screwed

Greetings,

I am using a sketch that is highly populated with ezbutton software code based on a .h folder. I recently downloaded the latest relevant seeeduino board updates and the software that used to work with my ezbutton (AVR) software no longer works and gives me a message suggesting this is a problem.

It sure wasn’t a problem before I downloaded the latest updates!

Can someone direct me to achieved XAIO folders for the Arduino IDE? I just need to go back in time a few days to the previous update.

Is this what you are looking for?

I bet you know better than I. IS that what I am looking for? All I know is that a variety of codes that ran this morning now fail to upload after being compiled.

I will post me woes there in hopes that someone may have some advice.

Oops, that’s no place for me. I do not understand anything presented on the screen. Just a bunch of folders with no apparent documentation. I am not a pro at this.

Hi BenderBud, I’m not sure if that’s what you are looking for. I am similarly not a pro. If you want to give that GitHub repo a shot, the ReadMe file does have the documentation on how to use it. Best of luck!

Hi, BenderBud.
Sorry; I don’t know if/where archived packages for the Seeed boards might be found.

However…

I know that some libraries don’t work properly with the newest Seeed samd board package (version 1.8.3 with files dated 24 May, 2022). I also know that, from time to time, the sloppy Seeed guys release “slightly different” packages without changing release version numbers.

So…
I just now used the Arduino Library Manager to un-install and re-install the Seeed SAMD boards package version1.8.3
I also installed the ezButton package, and I was able to compile all the ezButton examples with no errors.

I note that there is a warning from ezButton that the library “may be incompatible” with anything other than AVR boards, however the tests I ran have shown no problems. That doesn’t mean that there are no problems, but I haven’t seen any.

Bottom line: If you tell us exactly what the error(s) is/are, maybe someone can help you get to the bottom of things.

It’s possible that something other than ezButton library functions are causing your problems. (For example does your sketch have any libraries include <pgmspace.h>? That is a problem, but I might be able to figure out a workaround. I did for the Arduino_SSD1306 library, for example).

I attached a test program using ezButton that I used to show what happens when you don’t debounce a switch. And some output. If my little test program runs, then I doubt the problem is with the ezButton library, but we wouldn’t be able to determine the problem unless we can see more from you.

Regards,

Dave

Footnote:
The problem with <pgmspace.h> is that this stuff is totally unnecessary with samd cpus, and has been, quite properly in my opinion, relegated to a “deprecated-avr” subdirectory in the recent mbed compiler software used by Seeed. A “minor” edit in a library file may (or, maybe, not) fix the problem. Note that ezButton does not use this. A quick scan of the source shows things like digitalRead() and millis(). Nothing special that would create problems for non-AVR boards.

XIAO_ezButton_Bouncing.zip (1010 Bytes)

1 Like

Correction: The <pgmspace.h> problem showed up for certain other libraries using latest RP2040 board packages, not the “original” XIAO. I’m very sorry if my previous post caused confusion.

I stand by my tests of the ezButton library. We need to know more about your error messages and what other libraries you are using, and maybe we could see, at least, the parts of your code that caused the errors.

Regards,

Dave