I can't get Arduino IDE to download board package files for Seeeduino Lotus

I get the following 2 errors when booting Arduino 1.8.12 on Windows 10.

Error downloading https://raw.githubusercontent.com/Seeed-Studio/Seeed_Platform/master/package_seeeduino_boards_index.json

Error downloading https://files.seeedstudio.com/arduino/package_seeeduino_boards_index.json

I am trying to install the board package for Seeeduino Lotus.

  • I tried deleting the board package files in AppData.
  • I tried disabling my firewall.
  • I’ve tried selecting no proxy. And I confirmed I am not using a proxy with “netsh winhttp show proxy” at the command prompt.
  • I can go to the urls in the error messages with my browser successfully.
  • I tried saving one of the .json files and pointing Ardruino IDE to it locally. Another error.
  • The Library Manager is able to download information fine, so Arduino IDE is able to use my internet connection.
  • When I open Boards Manager it doesn’t have anything for Seeeduino Lotus.

I have tried almost everything from a similar thread. The interface won’t let me link to it. I’ll try to add the link later.

I’ve searched for how to install the board package manually, but I can’t find anything.

Is it possible to select a different board package, and it will be compatible with the board “Seeeduino Lotus V1.1 - ATMega328 Board with Grove Interface”? It has not been delivered to me yet. What happens if I try to upload to it with a different board package?

Help please!

I may have the solution.

Put the GitHub reference into Preferences >> Additional Boards Manager URLs
And NOT the seeedstudio reference! Even though the guide says to put both in.

I think this may apply to board support data for more than just Lotus. Trust GitHub and not others.

I still get tool errors when launching the Boards Manager:
“Index error: could not find referenced tool…”

But it seems that the Lotus board package is intact. I did notice it successfully installing that, and it’s part of the interface now.

My hardware is still in-transit, so I will have to wait and see.

I might try to install the missing tools in the meantime…

Hope this helps.


EDIT: Here’s the other thread that is related to this.

And here’s the thread that might be related to the tool errors.

This was an accident of the Arduino IDE, and I believe they have solved it.