[HowTo] [updated] Install the WIO Server on Raspberry Pi 3

Thanks, On Raspberry Pi 2 stuck on following Message :

[I 160430 11:14:40 server:535] SQLite version:

What is the problem ?

No problem here: this message indicates, that the server is running now. Congratulations :smiley:

OMG :blush: Thank you.

Now you can connect your WioLink with the Android App to this local server (using the IP address and port of the Raspi2).

Really Grateful

I am doing the same but when I try to read from the node(s) I get:
{“error”: “Please attach the valid node token (not the user token)”}

with curl I logged in (didn’t achieve it with postman) and also I did a list through curl to see my nodes

Also for FQDN I put my dyddns hostname

What am I doing wrong?

Hi Uwe,

Great manual !
I already wanted to this, but Googling already brought me to your walkthrough :smiley:

I used a stock Raspberry Pi 3, with Raspbian Pixel edition for the setup.
Your manual covered almost everything
I had only to change 2 things to make it work :

1 API not available for Wio
Initially, I got an 404 error, when trying to access the API of a linked Wio device
To fix this I had to config the 000-default.conf file :
(see the deploy script from the wio site)

2 Automatically start server.py
After the installation, even after manually running server.py and installing the firmware, I still got an error when trying to automatically boot it.
To fix this, I had to make sure the Raspberry waited until it had network connection before booting.
This can be set in the GUI or using the shell command :

sudo raspi-config
Boot Options/Wait for network at boot

Have fun !