How to load new firmware into DSOnano?

Good day to all.

I want to try loading new firmware into the DSOnano and I’m not sure how to proceed.

I’m at ST’s website looking at the myriad of files available for downloading and I’m not sure which files I need. … TM32F103VB

I see several possibilities:

  1. Flash loader demonstrator …

  2. DfuSe …

  3. STM32 Field-Oriented Control GUI … focgui.exe

  4. CDC driver …

Would someone be able to tell us which of those files we need?

Even better: could someone post a step-by-step procedure on exactly HOW to replace the firmware in the DSOnano?

Many thanks!



You can use DfuSe.

As target select internal flash.
With “Upload Action” you can choose a file and make a backup of your original firmware.
And i think it´s important to do so before you flash a new firmware, so that you can go back to your original!
With “Upgrade or Verify Action” you can flash your firmware.
simply choose your file, check the “Verify after download” checkbox and then press “Upgrade”.

Have Phun.

Hmm . . .

I seem to be having problems installing the appropriate driver.

I installed DfuSe as per the instructions that came with it. However, I was never given a chance to select a driver - plugging the DSO into the USB port causes Windows to give the “Found New Hardware” sound. Windows then informs me that it found a new USB Mass Storage Device and promptly installs the driver it thinks is best.

Essentially, nothing related to the DSOnano works.

I then opened the Hardware Manager, expanded the USB devices tree and uninstalled the Mass Storage Device driver that had been added.

Tried it again - same deal. Uninstalled the driver again.

I did try installing the STDFU driver manually by right-clicking on the STDFU.INF file and selecting “Install”. That did cause a change - I now get some messages when I connect the DSO - “eDesign DSO Flash Disk USB Device” as well as “USB Mass Storage Device”.

But running DfuSe Demonstration does nothing for me - it doesn’t see the DSO even though it is connected to a USB port.

I’m running Windows XP Pro, btw.

Any suggestions?



Hi, again :wink:

if the “eDesign DSO Flash Disk USB Device” is shown, the right driver is installed!

switch off your dso. press and hold the down button while switching on your dso to start in upgrade mode.

then start DfuSe. Now you should see your device…

hope it work for you…


Yes, indeed it now works.

The missing step was to put the DSOnano into upgrade mode by holding the 'Down" button while turning the power-switch ON.

However, I think that it might still be worthwhile to write a simple, step-by-step procedure so that other newbies won’t have so much trouble.

I’ve just gone through this - I’ll try to write a procedure. I’d sure appreciate it if others would amend it as necessary.

Thanks for the help!


Thanks to this thread, my DSO is now recognized by all three DfuSe programs.

I also had missed holding the down key when turning the DSO on.

Also, it took some time (maybe 5 minutes) for the driver to install from the “found new hardware”. I was almost ready to give up but remained patient (anxious!)

The device is now listed as “STM Device in DFU Mode” under “Universal Serial Bus controllers” in Device Manager. I am using Vista. It had previously been listed as something like “ST Mass Storage” under “Portable Devices”, if I remember correctly.

I would be glad to try to help (comment?) with the procedure write up. Not sure how good my help is because I am new at this - but having fun between periods of frustration!

My next step will probably be to try up upgrade to the v 2.21 posted several days ago. Hopefully, if I have problems, I can reinstall the v2.02

Just to document, I have DSO Nano v1.1, firmware v2.02 and Board v1.3A. I purchased Dec 31,2009 from NKC Electronics in the US. I am finding that many of the problems discussed in this forum apply to the beta and earlier versions.

I’m still not sure about the battery charging. I’m not yet ready to tear my case apart to look for components.

Can the firmware be updated on Linux or Mac? (Not including windows emulation.)
I think I know the answer, but there is always room to hope.