How to load Firmware into DSOnano

There are two sections to this post:

  1. A step-by step description of how to install the Windows software needed to load firmware into the DSOnano

  2. A step-by-step description of how to load firmware files into the DSOnano.

Section 1: Install the update software onto your computer.

  1. Install the ST DFU software. It is available from ST’s site: …

  2. Put the DSOnano into firmware update mode BEFORE connecting the USB cable between the 'nano and the PC. Do that by first making sure the DSOnano is turned OFF, then holding the “Down Arrow” button and then turning the 'nano ON.

The message on the screen should be “Please Connect to USB Host”.

  1. Ensure that you have the DfuSe “Getting Started” PDF file open in your PDF reader. This will make it easier for you to locate the correct driver - its buried deep in the Program Files folder on your boot drive.

You can find the Getting Started document by clicking the Windows “Start” button and going to Programs -> STMicroelectronics -> DfuSe -> Docs

  1. Connect the DSOnano USB connector to the PC.

  2. Follow the step-by-step instructions given in the above-mentioned Getting Started document.

Section 2: Loading Firmware into the DSOnano

  1. Start DfuSe Demonstration. You will find that by clicking the Windows “Start” button and going to Programs -> STMicroelectronics -> DfuSe

  2. Connect the DSOnano to the PC’s USB port if it not already connected. Ensure that the DSOnano is in the firmware update mode and that the screen is showing either “Please Connect to USB Host” or “Firmware Updating . . . Please Wait”

  3. Observe: there is a section near the top left portion of the DfuSe Demo screen titled “Available DFU and compatible HID devices”.

The selection box should say “STM Device in DFU Mode”.

  1. Now look to where the “Actions” title is. There is a box titled “Select Targets”. Ensure that the top line “Internal Flash” is selected.

  2. If you want to read the firmware out of the DSOnano and save it to a disk file, look at the section titled “Upload Action”. Click the “Choose” button, browse to your desired save location on disk, then either choose a filename to overwrite or enter a new filename. Then click the “Upload” button.

This reads the flash memory inside the DSOnano and saves it to a disk file.

  1. Now look to the section titled “Upgrade or Verify Action”. Click the “Choose” button and browse to where the new firmware files are stored on your drive. Select the correct filename.

Be certain that you load the files in the correct order if there are multiple files for that version of firmware. For example, FreeZinG says that for firmware version DS0201_V2.2X, “Burn the DS0201_LIB_V2.1_ss into the DSO first, and go on to download the DS0201_APP_V2.21 in the same way.”

  1. I also put a tick in the checkbox titled “Verify after download”. Your choice - I feel its best to ensure that the files make it into the device without error.

  2. Press the “Upgrade” button.

Repeat steps 6 and 7 for any additional firmware files if needed.

Done! Unplug the DSOnano from the USB cable and power-cycle the 'nano. The new firmware should come up.

Hope this helps!


I installed in 3 computers. All fine in 2, but in the last one (Athlon 64 3400, XP 32 bit SP2), the Dfuse application give me an error and doesn’t open up. I installed/removed (registry cleaned too) many time. Drivers also…
The DSO is correctly identified in the device manager, but Dfuse, crashes.

Any idea?

I can not run in on a xp version 2002 sp3 64 x2 4200+ amd processor as well. :cry:

I needed to install the DSO Nano update software into a new computer and figured that I’d go see if there was a newer version of the ST Microelectronics software available.

It turns out that there is a new version on ST’s website. The version that the first post in this thread referred to was DfuSe 3.0 from July 2009, the new version is 3.01 dated Jun 2010. You can use same download link posted earlier in this thread - I also found it at . Both links seem to point to the same version.

Not much has changed between version 3.00 and 3.01

  1. Both x86 and 64-bit versions are included now. That has doubled the size of the download package.

  2. The install routine now seems to install the appropriate driver automatically if you have the DSO Nano connected to a USB port AND the 'nano is in the firmware update mode.

Actually, I’m not sure if you have to have the 'nano connected - I did have it connected and the install package automatically installed the driver.

Remember that you get into firmware update mode by holding the down arrow button while sliding the power switch ON.

  1. Software is now WHQL Certified

Remember to uninstall any previous version if you are installing the new version on a computer that already had an older version installed.

One final note: it looked as if Windows didn’t understand what the 'nano was after the ST install routine had finished. It kept complaining that the USB device was unrecognized.

Looking at the driver details showed that both VID and PID were coming back as 0000.

Disconnecting the 'nano and power-cycling it back into firmware update mode, then reconnecting fixed the problem.

Hope this helps!


This may have your answer, and the answer concerns upgrade to V3.0.1.

EDIT: The link in this viewtopic.php?f=12&t=1429 is once again functional.


Can anyone tell me where I can find the DfuSe software? Neither of the links on this page seem to be working. I’ve gone around in circles on the ST site for about 30 minutes and I give up. Every search I do there gives me a a list of PDF’s referencing the 0412 software package, but never a download link for it.



This is the link directly from the DSO Nano V2 Manual.pdf file. I just tried it and it is working. …

I hope this helps.


Thanks Bill,

For some reason when I enter that link, it just sits there and churns. I finally hit stop after ten minutes or so. Maybe I’ll try later, but it was doing the same thing yesterday when I tried.

Is there a reason the software can’t be hosted elsewhere so as to not rely on ST’s website? The other thing I would suggest is a “meta” or something that gives links to all pertinent documents, software, etc., for the DSO Nano. It seems like I find bits of information scattered all over and I’m not sure if I’m missing something important.



Here’s the Google project link concerning all things DSO Nano:

I had the same problem and it sounds like v3.0.1 would fix. However, all download links on the ST Microelectronics website seems to link to the 3.0.0 version :unamused:. Hopefully the updated version will be available soon…

EDIT: I followed the download link supplied by Bilbo. Unfortunately, it downloaded the same 3.0.0 version that I was having issues with :confused:.

Thanks Norad2Kx - that did the trick!

For those looking for DfuSe v3.0.1, forum user lygra has posted a download link on this forum page:



The windows 7 is not recognizing the hardware DSO Nano, why can not I install the drive (STTub30.sys) located in the C: \ Program Files \ STMicroelectronics \ Software \ DfuSe \ Driver \ x86 …!

Please help me

German XP x64 running on an AMD x64 CPU does also fail to install the device driver for “STM Device in DFU Mode”.
An endless loop “new device found” (the DSO) does occur -> you can proceed the installation guide from ST as many times you want - but next to the loading of x64\STTub30.sys a message box does appear “… a file could not be found” (without any information what file is missing).
(tested: DfuSe v3.0.0, v3.0.1)

When windows ask for drivers you must select “install from…” and then select the “C:\Program Files\STMicroelectronics\Software\DfuSe\Driver[b]STDFU.inf[/b]” file.

My experience with dFuSe v3.0.1 (x64) installed at Win7 x64 home premium on a intel dualcore notebook:
STTub30.sys device driver installation is OK, DSO connection is working.

The Windows does not request the drive!
After installing the software dfuse v3.0.1, I plug the Nano into the USB port, but nothing happens! The Nano is not recognized by the system operacinal.

This window does not open to install the drive:

My operating system Windows 7 Ultimate 32-bit


Conect your DSO nano in boothloader mode, goto device manager, right click on “STM Device in DFU Mode” or similar and then select update driver.

Sorry my Spanglish :slight_smile:

Ok guys, the latest version is about 16Mbyte file size. Anything around 6Mbyte is the older V3.0.0 or earlier. The ST website only allows v3.0.0 downloads at this time. I am not sure why.

Here is the correct download viewtopic.php?f=12&t=1429 if you need the newer version. As stated earlier, the new version installs the driver automatically and it supports Win7 and 64 bit machines.