How do I know if my GPS module is not defective?

I received GEO kit. I assembled it and tried GPS example program that came with SDK. In the Monitor Tool the log file states a message “open failed”. That’s one of the INFO messages your example code writes to the log. I tried this with module exposed to an open sky as well. Seems to be not working. Is there a way I can find out if the GPSv2 module is working fine by sending it commands via the monitor tool? Please help.

The “open failed” is more like it can’t even reach the module - maybe defective module, maybe just bad connection. Check the cables first :slight_smile:

Hi, maybe you can check GPS as these steps.

  1. Downdload the Arduino IDE for RePhone( … ePhone_Kit );
  2. Select MTK USB Debug Port ,upload the GPS test code, …\Arduino_IDE_for_RePhone\hardware\arduino\mtk\libraries\LGPS\examples\gps_test;
  3. Switch the selected COM Port to MTK USB Modem Port and open the Serial Monitor;
  4. When have been located, these information will output. But if haven’t been located it also output information about a running UTC time.
    GPS UTC:16-2-19 2:20:21
    GPS status is A
    GPS latitude is N:22.587675
    GPS longitude is E:113.941322
    GPS speed is 0.070000
    GPS course is 21.940001
    GPS position fix is 1
    GPS sate used is 6
    GPS altitude is 78.809998
    GPS mode is A
    GPS mode2 is 3

@dbelam: Yes I did check the cable. It’s connected properly. Still not working. Thanks anyway.

@jinyuan.weng: well I am using Eclipse IDE with C, C++ SDK. I tried the sample program that came along with SDK which should output the GPS data on the monitor. No luck. Thanks anyway.

You should even check the pins on the module side - if you have a multimeter with small probes. I’d check both power and data lines.

Oh, and if you can hack it together: alexandru.m.ghe showed me a great Arduino project, called I2C scanner.
If that finds the GPS module, than it’s working. … lock&num=1

Just in case this helps…
I couldn’t get the GPS module to work using the Eclipse IDE so I reverted to using the Arduino IDE (flashed firmware first). Still didn’t work. Compared the Arduino example sketch gps_test with the hello_world example on the Wiki page. The gps_test uses the Serial1.print() function. The hello_world uses the Serial.print() function. So changed all the Serial1 to Serial. It now works.

(I’ll get back to Eclipse after I’ve done a bit of reading - not getting this Event-driven Programming Model at all.)