How best to connect to FILM ?

I have the beta (orange film) version of the Seeeduino FILM boards and am having some problems connecting to it with avrdude.
I’ve tried using the UART 3.3V connection and the ISP header connection.
I’ve managed to actually flash a new program onto the FILM using the USBtiny ISP programmer but that was only after about 10 tries
and consistently getting the message:

"avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check. "

It seems like the PTH on the FILM is very fragile/fussy and prone to not making contact w/ the header pins I’m using to pin the FILM down onto a breadboard.

Can the ISP header take 5V or does it also require 3.3V too ?

I’m very excited about the possibilities that the Seeeduino FILM presents, I will admit that I’m getting frustrated just trying to reliably upload to the board though.

Thanks for any help you can provide…


Yes, film is very fragile/fussy, sorry for that.
Did you use UartSBee upload a sketch to it, ever?
we are burn the Arduino Pro bootloader.
Can the ISP header take 5V or does it also require 3.3V too ?
Yes, please supply 3.3v.

all the best

No, just the USBtiny from adafruit. I have a BusPirate I could try.
I’m just trying to avoid have to buy Yet Another Programmer and then have to wait a week for it to ship here to the US.
Would it be damaged by 5V or will it tolerate that ?

Okay, good to know. Thanks.

I have a UartSBee now and it’s set to the 3.3V setting and is plugged into the Film board at the programming port.
I’m still not able to upload sketches.
I’m using the Arduino21 IDE.
When I try to upload the sketch I get one of these responses:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync(): not in sync: resp=0xbf
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0xbf

I have my board set to Arduino Pro/Pro Mini 3.3v ATMEGA168 and have the UartSBee plugged in and is recognized by my system.
I have the Film board running with the battery plugged in and the LED on the Film is blinking(It stops blinking briefly when the Arduino app is trying to upload the sketch.)

Any help you could provide would be appreciated.