Help with GSM/GPRS Shield

I purchased the GSM/GPRS shield. It is all communicating properly with an Arduino (I can pass and receive AT commands), but it does not seem to acquire a signal. When it start up it sends the following:


+CFUN: 1



The NetLight is doing a medium blank (the 800ms one) that indicates no signal, but I have verified that there is signal and the SIM card is working with another phone at the same location. I am using a AT&T GoPhone SIM card which is unlocked. I am in the United States. If I send a AT+CBAND? I get:


Is there something else that I need to set up or that I can check?

Any suggestions would be greatly appreciated.

PS. Attaching the antenna to the connector is very difficult. It looks to be attached properly, but is there any way to verify it, perhaps with an ohm meter?

The NetLight is doing a medium blank (the 800ms one) that indicates that SIM900 does not find the network, it does have to be no signal. You can try to use AT+COPS command(details please refer to datasheet) to see operators.

Thanks for your reply.

I tried AT+COPS and it returns “ERROR”

I tried AT+CSQ (signal quality) and received +CSQ: 18,0

You should use “AT+COPS?” , What i got is +COPS: 0,0,“CHN-UNICOM”. your signal quality is OK.
You can try to use another SIM card to see if still the same proplem.

AND please give me the following returns: