HELP! Windows 10 lost all USB COMS functionality

Help!

Yesterday while uploading sketches to XIAO my Dell Windows 10 Laptop
all USB COMS functionality stopped.
no da doo sound when connecting devices to USB no port detected, but power to XIAO board thru usb cable

same setup i been always using same hardware
tried all ports on computer no change
no device detected, no da doo sound no com port, but power to device

went to device manager no COMS and LPT section
Device Manager now says Other Devices - Unknown Devices

tried deleting deviced and update drivers say current drivers best

Searched internet, tried installing legacy devices - didnt work
Tried system restore point - didnt work
tried windows repair - didnt work
tried full wipe and reinstall windows 10- didnt work

any ideas?

Which XIAO is used? Is it Seeeduino XIAO?

update… i was afraid i had fried my computer usb host controler, but this morning was able to get a usb thumb drive to be recognized in the ports and it made the da-doo sound when pluging and unpluging

it still says com 3 which was the com the XIAO was using is yellow!

it seems i probably need to remove the XIAO configuration files but dont know how to do that
in the usb host controler… the part that says hey we know who you are you been here before

ok update i got my other XIAO and plugged it in and everything connected as supposed to
so atleast thats a good sign… it came in as com 4 when the othe was com 3
i deleted the old from device manager but it still is not recognized

i guess i will have to take it to another computer next and see what happens

ok aparently my XIAO serial must have died… it is no longer detected on eithe of my computers