Help, DSO nano v3 only turns on when connected with USB

Hello, I have had a v1 which works great for years, just yesterday I got the v3 from Amazon, but the dso does not turn on.

I thought the battery was dead but after letting it sit overnight the next day it still did not turn on, the screen lights up but you get no image.

I have used the latest firmware along with Benf’s also, both have the same problem.

Now here is the weird part, I connected a mini usb to usb cable and attached it to my multimeter to measure current and the battery is charging, but does not turn on if I remove the cable

But if I connect the positive from the usb to the outside (ground) of the usb it turns on. Why?

Want to see if it is maybe something I am overlooking.

Attached some pictures, hopefully I can fix this without returning it, thanks in advance.

Looks like the battery is too low to drive the circuit. Maybe you should charge for a long time.

If still not working, please check with the following steps:
S1: plug the usb cable, measure the voltage between + and - of the battery pin. -> Should get ~4V, if not, the charging circuit may be broken.
S2: unplug the usb cable, measure the voltage of battery -> if > 3V, your Nano may be out of order.

Hope helpful for you.

I returned it maybe about a week after posting this when I saw I got no reply, got another one that worked just fine, though I am still using my ds201 since I don’t have a 10x bnc probe, its in the mail. Already got a 3.5 to bnc adapter, but not a probe.

The charging voltage and the battery resting voltage was good, the battery would charge and it would also hold that charge, I never found out what was wrong with it.

I have the same problem with DSO nano v2

The problem is still there because I don’t know where to fix it in China.

Recently, I have the same case. In my case, the connector, between battery and PCB, didn’t connect tightly.